Windows SourceTree Working Copy URL Shows as Not a Valid Working Copy Path

I am getting an issue pulling a working copy from bitbucket to my windows sourcetree install. When I put the URL in, I am able to clone the repository just fine, and it verifies it as a valid copy. However, when I try to pull down a working copy, it comes back with "This is not a valid working copy path."

Is there something I'm missing?

1 answer

1 accepted

This widget could not be displayed.

When you say 'Pull down a working copy', do you mean you're using the second tab labelled 'Working Copy'? This tab is used to point SourceTree at an existing clone you already have on your disk. If you're cloning, you don't need to use this tab because the act of cloning creates a working copy as well, which SourceTree then bookmarks. You only need to use the Working Copy tab if you've cloned outside of SourceTree and need to bring that existing clone (and working copy) in. That second tab will only accept local paths which point to an existing valid cloned working copy.

That's exactly what I needed to know! Thank you!!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

877 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you