Windows 10 sourcetree installer won't accept my credentials

Hi There,

 

I've just downloaded the installed, clicked 'use an existing account', entered my details and I get the message

'Something went wrong while attempting to validate your credentials.'

I've even tried resetting my password.

Any ideas?

Thanks

Ben

 

1 answer

6 votes

Hi Ben! Can you try logging into your Atlassian account using your borwser directly? Sourcetree relies on Internet Explorer, so make sure you're using an updated version. If trying in the browser doesn't work either, can you try the following?:

  • Turn off compatibility mode in IE. To do that, open Internet Explorer, go to the Advanced options tab and click on Reset your Internet Explorer Settings
  • Check Delete personal settings
  • Change your Internet Explorer Security Zone Settings:
  1. Open IE, click on the gear
  2. Select "Internet Options"
  3. Select the "Security" tab
  4. Select "Custom Level" for Internet
  5. Find "Access data sources across domains" and select "Enable" (make note of what the setting currently is)
  6. Try logging into Sourcetree again

After logging in, follow steps 1-5, but reset the setting back to the previous option.

If the browser works but you still get that error in Sourcetree, let's have a look at the logs and let us know which Sourcetree version are you using.

Best regards!

Ana

@Ana Retamal Ortiz Hi Ana,

The browser login is working fine for me but facing same issue when trying to login with app. 

Sourcetree version : 2.5.5

Here is the log: 

ERROR [2018-05-29 18:36:45,631] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2018-05-29 18:51:07,303] [1] [SourceTree.AppRoot+<OnStartup>d__33] [MoveNext] - Preflight checks failed! Continuing to run SourceTree

Thanks,

Gaurav

Hi @Gaurav Sadhwani, please navigate to the config file location (C:\Users\{USERNAME}\AppData\Local\Atlassian\SourceTree.exe_{RANDOM_GUID}\2.3.1.0\user.config), find the following line:

<setting name="AutomaticallyCleanUpDictionaryFiles" serializeAs="String">

   <value>True</value>

</setting>

And make sure that value is set to True

If after that you're still having issues, we'll need more information to help you with this:

  1. What error message do you get? Can you send us a screenshot?
  2. When does this exactly happen? (Are you trying to install? Are you trying to start the application?
  3. Have you been able to go through the installation phase?

For the future, keep in mind that it will be better if you submit a different post for your question (unless you're completely sure what you're experiencing is the same as what the author posted) for higher chances to get your problem solved.

Best regards :)

Ana

When I login from internet explorer, I get a " Forbidden — Bitbucket

CSRF verification failed. Request aborted."  error.

 

This is probably what is happening behind the scenes when installing SourceTree?? How to resolve? Installs fine on Windows 7.

 

I'm installing 2.6.9.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

828 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you