Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why won't UI refresh after staging in files in Sourcetree Version 3.3.6 ? Edited

I updated Sourcetree a few days ago to Version 3.3.6.  Since then, the user interface does not update itself after I commit files, or change branches.  It's like I didn't really do the thing that I just finished doing.  If I close and reopen Sourcetree, Things come up correct.

Was there something in the last release that broke the user interface refreshing itself after certain operations?

Here's some steps to reproduce the problem I'm seeing:

1. Change some source files so that they appear in the 'Unstaged files' area in Sourcetree.

2. Select all the files

3. Click 'Stage All'

4. For me, the files all stay in the 'Unstaged Files' area and the 'Stage All' button disables.

5. Click onto a different project folder and then back onto the folder you started with.

6. The files are now in the 'Staged files' portion of the screen and the 'Stage All' button is enabled

 

 

10 answers

This appears to be a serious bug in 3.3.6.

It is also discussed (with a workaround) here: https://community.atlassian.com/t5/Sourcetree-questions/Manual-refresh-required/qaq-p/1256362

I hope Atlassian are noticing this feedback?

Removing the bookmark for the repo (close the tab) and then re-opening a tab fixed this for me. 

great tip, thanks! Been driving me nuts for a while! 

Same thing happened to me. I got so frustrated, I downgraded back to 3.3.4

Same thing happens on the latest 3.3.7.... I have to manually hit F5 after every button click and command and staging, adding, pushing, pulling, on every screen, to see any sort of updates.

 

So still not fixed...

I'm having the same issue after upgrading to version 3.3.6. Very frustrating and I'm hoping Atlassian are following this issue. Another work around other than re-starting is to move the window to another screen. (This worked for me as I have a dual screen setup)

I'll probably downgrade and hope this gets fixed soon.

 

Thanks to @curtiscode for starting this thread with the issue.

Same issue,

 

Seems Version 3.3.6 has so many other problems.

It needs fixing asap

I'm also having the same problem.
A work-around (without having to restart Sourcetree) is to select a different option from the File Status drop-down, the change back to your previous selection (for me, I go from Pending to Untracked then back to Pending). Changed source files are then shown.
SHOWING the files is ALL it fixes, though.
If I stage/unstage, I have to switch the drop-down option again to see the UI updates.
Same thing if I make a commit.

Haven't figured out a work-around for the lack of branch updates (for example, after making the commit, the number on my branches doesn't increment for the number of commits different from remote. I have to restart to fix that. Same for after I push to remote.)

I really hope they fix this soon. I'm downgrading until they do.

Encountered the same issue myself on upgrading to 3.3.6

Downgraded back to an earlier version.

 

This is critical functionality that has regressed, please fix this as soon as possible.

Version 3.3.6 is unusable until this issue is resolved.

It's still in 3.3.7...

This has been fixed in 3.3.8.3848

Download link

https://product-downloads.atlassian.com/software/sourcetree/windows/ga/SourceTreeSetup-3.3.8.exe 

 

I manually downloaded and installed the update. (The automatic update failed as well so forced the upgrade)

being blocked by windows as it doesn't seem to be signed correctly.

 

Windows protected your PC Windows Defender SmartScreen prevented an unrecognised app from starting. Running this app might put your PC at risk.

Application:SourceTreeSetup-3.3.8.exe
Publisher: Atlassian Pty Ltd
Like KEMBL likes this

Yep. Windows 10 does not allow 3.3.8 "Windows Defender SmartScreen prevented an unrecognized app from starting. Running this app might put your PC at risk."

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,236 views 19 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you