Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Manual refresh required

tm8544 December 21, 2019

Windows app version 3.3.6

App does not detect local file changes, unless I refresh manually (F5).

Also, after staging files I need to refresh manually to see the files in "Staged files" section, otherwise they are still displayed in "Unstaged files".

In options, 'Refresh automatically when files change" is selected.

With version 3.2.6 there was no such problem.

 

14 answers

1 accepted

5 votes
Answer accepted
HaRii66666 January 6, 2020

i just had the same problem. no matter what i did, nothing refreshed. 

after some googling i found this other thread and the accepted answer fixed it for me, which was to delete repository bookmarks.

Alan Mitchell January 6, 2020

Oh. Yup, solution from 2013 did work. After deleting all my bookmarks, not just the current project.

Weird, but thank you @HaRii66666 

 

UPDATE - 16th Jan.

It's broken again.  Weird.  Annoyiing.  BUGGY.

Like HaRii66666 likes this
HaRii66666 January 6, 2020

i may also add here that i only got one bookmark which i deleted in case it makes a difference.

you're welcome @Alan Mitchell  :) 

tm8544 January 6, 2020

What bookmarks does this mean? Browser bookmarks?

HaRii66666 January 6, 2020

@tm8544 this one

tm8544 January 6, 2020

Thank you @HaRii66666 

Steve Romanow January 13, 2020

On 3.3.6, this did not work for me.  I deleted 4 bookmarks (not the repo, just the bookmark) then recreated them by drag and drop from explorer.  Still no refresh, restarted ST and still no refresh.

HaRii66666 January 13, 2020

@Steve Romanow i am not sure what the underlaying issue here is anyway, but have you tried not using those bookmarks at all? 
(i have never used them before and didn't even know they are there ^^) 

Steve Romanow January 13, 2020

I do not use the bookmarks myself.  I was just following what others were doing to try to fix the "F5 refresh" required after every ST maneuver.  Updated to 3.3.6 today and with every checkout, commit, stage, etc, the ui does not refresh automatically as it used to.

Cátia Gonçalves January 15, 2020

Didn't even know I was using a bookmark (apparently it gets setup by default).

Followed steps in here (in 3.3.6 it's called "Toggle Bookmarks Sidebar" instead of "Show/Hide Bookmarks"), selected the only link there, right-click and "Delete". I also added it back just in case, by dragging the project folder from explorer into the sidebar. And it worked like a charm!

Thanks!

Version: 3.3.6

OS: Windows

Steve Romanow January 22, 2020

STILL BROKEN

The method here worked the second attempt, for the day.  Today it is back to not working.  I may need to roll back to previous release.  3.3.6 has been out for weeks and I have not seen anything official from Atlassian here.

Bruce Kinchin January 28, 2020

Thanks @HaRii66666 ... great find. This solution worked for ,e

Steve Romanow January 29, 2020

I think I have a solution. 

I did not use the Sourcetree upgrade.  I uninstalled and reinstalled using the 3.3.6 media.

Cleared local files per this link.

When I needed to set my configuration up, I made sure to use "Add"to relink my local working directories to their remotes.

 

Looks good so far.  This appears to be breakage in upgrading.

Steve Romanow January 31, 2020

After uninstall and reinstall, it is back to not working maybe 24 hours later.

Steve Romanow January 31, 2020

Appears to be this ticket. Confirmed if I move my main repo to a tab other than tab one, the problem only occurs on tab 1.

1 vote
abioneperhobby January 16, 2020

as reported by https://community.atlassian.com/t5/user/viewprofilepage/user-id/3692847 , removing all the bookmarks solve the problem 

Steve Romanow January 16, 2020

Are the bookmarks required for normal functioning?  Remove and replace did not work for me. I will try again, but problem still occurs on my workstation.

Like YUAN-HSUN TANG likes this
Steve Romanow January 20, 2020

Update on my resolution: the bookmark removal did work for me the second attempt.  I think the difference was this time I deleted the bookmarks and did not replace.  Not sure why i would need the bookmarks.

1 vote
Alan Mitchell January 3, 2020

Same here.  Fresh laptop, new install. Complete PITA.

This is a serious bug, please give it some attention asap!

1 vote
dsmoore1600 January 2, 2020

I have been having the same issue. This makes the product almost unusable. Another part to this that I have noticed is that if I push a branch to origin it does the push and displays an error message, then after I click ok on the error message it and then refresh the history view it is showing that the branch pushed successfully. I just so happen to have just rebuilt my machine, so there shouldn't be any other circumstances impacting this issue. 

0 votes
Pascal BARBAULT February 1, 2020

I got same issue after updating SourceTree with latest release (3.3.7 for Windows).

Pressing "F5" was required to refresh display properly after this update.

Deleting bookmarks fixed this issue at my end.

Thank you  @HaRii66666 

0 votes
mike_entyce_creative January 23, 2020

I've just downgraded to 3.2.6 and it's working fine now:

https://sourcetreeapp.com/download-archives

0 votes
YUAN-HSUN TANG January 22, 2020

Thanks for the reply above, but why it was working before?

This issue occur after I updated to 3.3.6

0 votes
Andy Liddle January 17, 2020

The workaround is to delete everything in:

C:\Users\USERDIR\AppData\Local\Atlassian.

It does mean losing settings every time which is just crazy.

 

Another workaround is to use GitHub ;-)

0 votes
abioneperhobby January 16, 2020

the workaround is to change git client, but sourcetree is the only one i know that permits to ignore ssl certificate issue :-D

0 votes
Nitesh J January 16, 2020

pressing F5 is also a workaround -> I Don't want to lose my bookmark (the one that got setup by default

0 votes
Jura Khrapunov January 2, 2020

Same here, quite a bummer :-(

0 votes
Rajeev Francis December 31, 2019

I am also struggling with the same issue

0 votes
ScottThomas07 December 29, 2019

I have the same issue. In addition to what's been said already, I also need to refresh after fetching.

0 votes
kingofzihua December 26, 2019

I also encountered this problem and it was really frustrating! For this I have given up and used terminal commands to operate. Simply disappointed!

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events