Why do I get this error when entering my correct password when prompted to do so when pushing

2018-01-17 12:01:45.244 git-credential-sourcetree[28574:1187908] Error generating password due to missing uuid. Please report this to Atlassian.

2018-01-17 12:01:45.246 git-credential-sourcetree[28574:1187909] Something went wrong. one or more parameters required to renew token is nil.

2018-01-17 12:01:52.841 git-credential-sourcetree[28574:1187908] Error generating password due to missing uuid. Please report this to Atlassian.

2018-01-17 12:01:52.841 git-credential-sourcetree[28574:1187908] Password encryption failed - key to to encrypt password is unavailable (nil)

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

This error is given when I attempt to push to master on the SourceTree GUI after asked for my password.

I enter the guaranteed correct password and then get this error and do not push to master as desired. 

I originally made my account with Google sign-in, then added a password to my account since the error told me to do so.

I am on MacOS and this error did not happen to me before the newest update.

Using the terminal allows me to push, but I don't use SourceTree for the terminal.

10 answers

Can you confirm the macOS version you are running on?

I'd recommend you to delete the com.torusknot.SourceTreeNotMAS.plist located at ~/Library/Preferences/ and launch the app again. This should generate the missing UUID and allow all actions thereafter. 

Thanks!

High Sierra 10.13.2

Thank ya sir.

After upgrading to 2.7 also on OS 10.13.2 I'm getting the following error:

Pushing to https://xxx@bitbucket.org/xxx.git
2018-01-29 13:44:47.896 git-credential-sourcetree[xxx:xxx Something went wrong. one or more parameters required to renew token is nil.
2018-01-29 13:44:54.825 git-credential-sourcetree[xxx:xxx Password encryption failed - key to to encrypt password is unavailable (nil)
remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.
fatal: Authentication failed for 'https://xxx@bitbucket.org/xxx.git/' 

Deleting the suggested files didn't work.

Can you help?

I found other solution by 

- going to KeyChain app on your Mac

- click the lock icon and then unlock on the top-left of panel

Then try login again. 

If it still doesn't work, combine with deleting solution and try again.

 

That's work for me. Hope it helps.

Thanks Nui Rattapon, but that didn't work. However, I'm a step towards identifying the problem: SourceTree isn't saving the password in Keychain even though the option is checked in the password modal.

Looks like downgrading is the only solution at the moment:

https://community.atlassian.com/t5/Sourcetree-questions/I-can-no-longer-push-after-updating-Mac-to-sourctree-v-2-7/qaq-p/704950

We've had some report of this and got a fix in the latest beta. Would you mind trying that and share your feedback?

You can download the latest beta build here

 https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/OSX_Beta_Latest.zip

It is safer to remove any keychain items that might be present for the account before trying the new build. This is just to ensure that you save the right credentials again and the old ones that may cause any issue are removed. 

Thanks!

And yes, please ensure you remove other passwords saved by sourcetree before to avoid conflicts/unsuccessful logins at launch. 

Sorry, Beta gave the following error:

Pushing to https://xxx@bitbucket.org/xxx/xxx.git

2018-01-30 12:21:52.466 git-credential-sourcetree[xxx:xxx] Error generating password due to missing uuid. Please report this to Atlassian.

2018-01-30 12:21:52.474 git-credential-sourcetree[xxx:xxx] Something went wrong. one or more parameters required to renew token is nil.

2018-01-30 12:21:58.680 git-credential-sourcetree[xxx:xxx] Error generating password due to missing uuid. Please report this to Atlassian.

2018-01-30 12:21:58.681 git-credential-sourcetree[xxx:xxx] Password encryption failed - key to to encrypt password is unavailable (nil)

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

fatal: Authentication failed for 'https://xxx@bitbucket.org/xxx/xxx.git/'

and I don't see any passwords saved in keychain 

And now the version I downgraded to - 2.6.3 - crashes and is unusable :(

Edit: Deleting the beta solved this.

Facing issue with changing password, deleted Sourcetree application password from keychain access. SourceTree prompt for new password and check for store in keychain also set. Still getting same error.
As per comments here, I tried with Beta version also, deleted password from keychain to avoid any conflict, before using Beta version.
Continue showing same error "token is nil" appearing each time yesterday. So I installed Sourcetree application(not Beta) again.

Today I start work, its working fine. I think machine restart is required. )

Not sure why this is marked as an accepted answer. None of the solutions (other than a downgrade) seem to work. Luckly the command line git works fine pushing and pulling to bitbucket. Seems like I'll have to abandon SourceTree for a bit

The Beta fix doesn't work. I'm using Bitbucket Server and I tried every fix you've suggested. The bug is in SourceTree, not everywhere else.

Protocol: HTTPS. Not SSH. There's no SSH port for my company's server.

Well i had issues again after it was working with the beta. This time some different method. But this has been working now for couple days.

 

See this link

Hi @Patrick Fowler and @Bill Cernansky, I've contacted our developers regarding your concerns and they informed me that they've already fixed part of the issue, which will be out in the next release. The rest is being currently investigated and will be fixed soon.

Stay tuned!

Ana

Vincent Hooft I'm New Here Sunday

The Beta does not solve the problem, I do not hope that the developers are hoping for that.

Vincenzo Coia I'm New Here Monday

Beta also does not work for me. Mac OS High Sierra 10.13.3. Deleting source tree and reverting to 2.6.3 works for me.

Find the archives here: https://www.sourcetreeapp.com/download-archives

1 vote

I facing the same problem here and deleting the com.torusknot.SourceTreeNotMAS.plist still doesn't work. Any other solution?

We've had some report of this and got a fix in the latest beta. Would you mind trying that and share your feedback?

You can download the latest beta build here

 https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/OSX_Beta_Latest.zip

It is safer to remove any keychain items that might be present for the account before trying the new build. This is just to ensure that you save the right credentials again and the old ones that may cause any issue are removed. 

Thanks!

I'm having the same problem. The solution above, including the BETA version did not solve the problem for me.

This occurred first when I (for another customer) added shh. Maybe that points someone in the right direction?

0 vote

I was having a similar issue.

A temporary fix worked for me, as follows:

Revoking access via bitbucket (settings -> Oauth) and then changing login credentials to basic https instead of Oauth fixed the problem for me.

Not ideal but it's allowed me to use git again.

the beta doesnt work for me neither on 10.13.1 

Tried deleting the account in the beta app, deleted keychain item, deleted local repo. 

SIgned in using Oauth using SSH, it first show icon avator so its connected. Then imported remote git, tried some update and the pushing status is infinite. Than i cancel that go back to account settings and see the missing avatar icon again, so again back to square 1.

Are these beta apps properly tested???

Im new to this forum, tried adding a second note here and keeps beeing deleted some how???

 

Found a stack exchange post.  using this worked for me using ssh, using the beta version

ssh://git@github.com/schroef/TheaForBlender.git

 

Seems like the input is wrong when the app is used and account is setup?

For all those using ssh, please check if the ssh-agent has your keys loaded. If not, please add them to the agent. 

Run below commands in terminal to do so,

To check if keys are loaded:

ssh-add -l

To add keys to agent:

ssh-add <path_to_key>

more like,

ssh-add ~/.ssh/id_rsa

Key in the passphrase used while generating the ssh key and you should be good to go. 

@Rombout Versluijs I'm sorry your posts kept disappearing -- they were being caught by our spam filter. You should see them again -- let me know if any duplicates need to be deleted.

Also nice Dutch name! :) 

Hahaha really, my name is to difficult for most Dutch, lets stand for foreigners ;)

Thanks for helping, The post below this one can be deleted.

@Manjunath Basaralu Srinivasa Well do input those command from the desktop app. When i tried 

ssh-add -l

in Terminal root i got

The agent has no identities.

Why should there be a ssh folder in the root, isnt it a connection type? 

Found this in a stack exchange post. https://stackoverflow.com/posts/30552441/revisions

 

using this worked for me using ssh, using the beta version

ssh://git@github.com/schroef/TheaForBlender.git

 

Seems like the input is wrong when the app is used and account is setup?

Found this in a stack exchange post.  

using this worked for me using ssh, using the beta version

ssh://git@github.com/schroef/TheaForBlender.git

 

Seems like the input is wrong when the app is used and account is setup?

 Im new to this forum, tried adding a second note here and keeps beeing deleted some how???

 

Found a stack exchange post.  using this worked for me using ssh, using the beta version

ssh://git@github.com/schroef/TheaForBlender.git

 

Seems like the input is wrong when the app is used and account is setup?

I am having similar issue with version 2.7.1 (159) on MacOS 10.12.6.

I have two different BitBucket Servers to which I am connecting. The first one is BitBucket Server version 4.7.1 which I connect to via HTTPS protocol (actually the url is just http://foo.bar:7990). The second one is BitBucket Server version 5.7.1 which I connect to via HTTPS protocol (and the url for this one is actually https://baz.bar:8443). 

I have tried using the Beta version 2.7.1 (155) and the issue still persisted. I have deleted all passwords from KeyChain Access with no success. I also tried completely uninstalling the application and deleting both ~/Library/Application Support/SourceTree and ~/Library/Preferences/com.torusknot.SourceTree* and then reinstalling again with no success. 

I also tried reverting to 2.6.3 (134) and that seems to partially solved the issue. I now no longer get the error when working with server version 4.7.1 and I can see the password for that in KeyChain Access. However with server version 5.7.1 I don't see the password in KeyChain Access and every time I interact with that server I have to enter the password twice before this succeeds. 

What is the best way to report this issue to Atlassian? I am not sure if it is helpful or not to post the a question that has been marked as solved which it seems like many users are still having issues with.

Hi @Thomas Nelson,

I hope "foo" and "baz" aren't the same in the example above. Also, are the usernames same?

You can file a ticket on https://jira.atlassian.com/projects/SRCTREE/

"foo" and "baz" are not the same servers but my username and credentials are the same on foo and baz.

Remove the account that isn't saving your password and try adding again. If the password gets added to keychain, I'm sure it will work. However, there are cases where either due to a permission issue or an old duplicate keychain item with the same name, Sourcetree cannot save your password to keychain. Re-adding account helps most of the time and restarting the mac fixes permission issues most of the time. 

I tried removing the account and adding it again. No luck. I also tried restarting but still no luck. The password for baz is not appearing in Keychain and every interaction requires me to enter my credentials twice before it works. 

I have also filed a bug in Jira to track this issue.

try this link, i have now a working beta version

I suppose that's good for SSH users. HTTPS users are still out of luck.

@Rombout Versluijs Looks like that link only helps if you are using SSH. Hopefully that will be helpful to other users that are using SSH. Unfortunately the servers I am connecting to use HTTPS and not SSH. If you run across a solution that works for HTTPS please let us know. Thanks!

You can easily switch to ssh, have you tried following those steps?

It's not whether I personally can easily switch. The situation is, only HTTPS is offered on the servers we are accessing.

I cleared any Sourcetree related passwords in Keychain, Revoked the Oauth in my Bitbucket account, used the beta version in this thread and now thank goodness it's not asking for my password over and over anymore. 

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

274 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot