I can no longer push after updating (Mac) to sourctree v 2.7

I just updated Sourcetree today on my Mac and now I can't push.  I can pull and everything works well there but when I push I get the following error:

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree push -v --tags origin refs/heads/master:refs/heads/master 


Pushing to ssh://[mygitlocation].git
Permission denied, please try again.
Permission denied, please try again.
[address]: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
Completed with errors, see above

Is anyone else experiencing this after the update (v2.7)?  Can you help me please? 

10 answers

1 accepted

2 votes
Accepted answer

Mike,

I had the same issue along with some of my colleagues. I downloaded the older version (2.6.3) and this fixed my problem. Hopefully the devs can get this worked out.

Thanks for getting back to me on this Caden!  That did the trick for me as well. I appreciate your help.  

Hi guys I have the same problem with a different error but I am not able to download the previous version from this page because I get a 404.

Do you have any idea on where can I get it?

Thank you in advance and all the best,
Andrea

Andrea,

 

Here is the page where you can get 2.6.3 downloaded:

Download Archives

 

Cheers!

Hi Caden, thank for the advice but is the same page I liked earlier but this link does not work: https://downloads.atlassian.com/software/sourcetree/SourceTree_2.6.3a.zip

Sorry about that. I didn't see that you linked that page.

 

I found the problem though. 

At the end of the link it should be

Sourcetree_2.6.3a not

SourceTree_2.6.3a

Same problem here, just updated to SourceTree 2.7 (152) and I can't push anymore:

git-credential-sourcetree[18276:983688] Error generating password due to missing uuid. Please report this to Atlassian.

2018-01-22 16:32:40.461 git-credential-sourcetree[18276:983689] Something went wrong. one or more parameters required to renew token is nil.

2018-01-22 16:32:43.589 git-credential-sourcetree[18276:983688] Error generating password due to missing uuid. Please report this to Atlassian.

2018-01-22 16:32:43.590 git-credential-sourcetree[18276:983688] Password encryption failed - key to to encrypt password is unavailable (nil)

fatal: Authentication failed for...

Downgrading to 2.6.3 solved the problem

Hi!

I have the same problem too.

After upgrading to 2.7 (152) a week ago, I can't push or pull to any repository . I use BitBucket repos and a self hosted repos with GitLab.

Every repo is working well if I use GitKraken :-( I don't like GitKraken!!!

I'm trying to downgrading

 

Thanks!

Downgrading to 2.6.3 solved the problem for me too

@Caden Mahoneythank you so much! I didn't notice this before! Now I'm able to push again!!!

Some two weeks later and 2.7 152 is still being sent out as an upgrade. I just spent hours trying figure out why push quit working before found this thread.

I think I've saved others in our group the same problem. 

Was able to go back to an older version using a timeMachine backup.

We've had some report of this and got a fix in the latest beta. Would you mind trying that and share your feedback?

You can download the latest beta build here - https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/OSX_Beta_Latest.zip

It is safer to remove any keychain items that might be present for the account before trying the new build. This is just to ensure that you save the right credentials again and the old ones that may cause any issue are removed. 

Thanks!

I tried the latest Beta just now and it still doesn't work!

I also tried the beta and still got the same error.

For all those using ssh, please check if the ssh-agent has your keys loaded. If not, please add them to the agent. 

Run below commands in terminal to do so,

To check if keys are loaded:

ssh-add -l

To add keys to agent:

ssh-add <path_to_key>

more like,

ssh-add ~/.ssh/id_rsa

Key in the passphrase used while generating the ssh key and you should be good to go. 

But I try authenticating with username and password and not my SSH Key.

Can you verify if the remote URL for the repo is https or ssh?

Yes, the remote URL starts with ssh

You can either follow the steps above and get your ssh setup working. If you want to switch over to using https, right click on the repository bookmark in the Repository Browser window and you will have an option to "Convert to https". Click on that and from then on, Sourcetree will use the username/password for basic auth or username/access token for OAuth accounts.

So my only options are to get the Server working with SSH Key authentication or switch to https if I want to use version 2.7?

Let‘s see what our server admins say. 

The solution from Manjunath Basaralu Srinivasa (above) worked for me using SourceTree 2.7 on on macOS 10.12.6:

ssh-add ~/.ssh/id_rsa

 

The solution from Manjunath Basaralu Srinivasa (above) did not work for me using SourceTree 2.7 on on macOS 10.11.6:

What is the new error? 

Are you able to see the list of keys when you try to list them in terminal?

I also reverted back to version 2.6.3  because username/password authentication with ssh:// URLs  seems not to be supported anymore. 

Yes, I can.  I even tried creating new keys dsa, rsa, ecdsa and no luck.  However, I did get a work around from this other community thread. 

Where does branch name come from for svn dcommit

Using this work around I was able to push to my SVN remote...

Beta still fails for pushing to Bitbucket over https:

Please provide the error messages that you are seeing. 

I'm sorry, I should amend this: Beta still reports errors pushing to Bitbucket over https: , but it goes through anyway. The same errors that are reported about "Error generating password due to missing uuid".


Hi, I downloaded SourceTree 2.7.6 today, and encountered same error, git works fine in terminal but so I am denied access to all remote git operations with sourcetree.

 

problem solved after adding the key to ssh agent using below command

$ ssh-add -K ~/.ssh/id_rsa

BUT!!!!!!!!!!

after some experiment I think the private key must be named  id_rsa for SourceTree to work, which is an inconvenience and should be solved by sourcetree developers!!!!!!!

Ridiculously incompetent dev team.  Same issue here because I was stupid enough to update to 2.7.6.  Using https and no git pull actions will complete, they just endlessly hang.  

Maybe Atlassian should invest in a real QA team and/or competent devs.  

I had the same error!! Is there a bug with the version 2.7 on Mac High Sierra? 

Bug is evident in Sierra too. It's not everything else. It's SourceTree's fault.

I tried the beta version with no success. Reverted to 2.6.3 and all is well. Thanks, @Caden Mahoney!

I am also having this issue with private repos since 2.7 and the beta didn't fix it.

I have the same error than Mike in addition to the following line:

ssh_askpass: exec(/usr/X11R6/bin/ssh-askpass): No such file or directory

Here is where I am at:

  1. At first, I had the «Permission denied» message described above.
  2. Then I installed ssh-askpass: it did work but it kept asking my password.
  3. I finally added my public ssh key to the authorized_keys file of my private repo server to skip the issue... which is not the best when we have a lot of collaborators.

I have the following configuration:

  • Using system git (version 2.15.1)
  • OSX 10.13.2
  • SourceTree 2.7 / 2.7 beta

New version 2.7.1 (159) solved the issues, but first I had to uninstall and remove my ~/Library/Application Support/SourceTree folder. 
I kept a copy of ~/Library/Application Support/SourceTree/browser.plist (bookmarks). Once I reinstalled the new version, opened it to initialize, I was able to copy back the browser.plist to retain my bookmarks. 

Updated, deleted folder, started again, copied back the browser.plist file ...

 

Still having problems ... I'm using a gitlab (self hosted) repository accessed via https, still asking for password all the time I assume for any repo on the list ...

 

Returned to the 2.6.3 and no problem at all :-(

 

What I'm doing wrong?

use 2.6.3 fixed the problem, the latest version 2.7.1 also has the issue

Still have this problem with 2.7.3

Please make sure you add the ssh key to the agent. Instructions are in my comments above. 

I downloaded SourceTree 2.7.6 and encountered same problem.

problem solved after adding the key to ssh agent using below command

$ ssh-add -K ~/.ssh/id_rsa

 BUT after some experiment I think the private key must be named  id_rsa for SourceTree to work, which is an inconvenience and should be solved by sourcetree developers!

Not necessarily, you can name you key whatever you want. But, add the same key to the agent. 

for example,

ssh-add -K ~/.ssh/yoursshkeyname

Thanks for the reply. Yes we can give the key a name other than ”id_rsa” and we can add it to the agent.

The SourceTree app may have some machinations to detect the name of the key in the agent, but it is not working very well. I don’t want to test anymore, the developers could do the test.

And unfortunately, I couldn’t find where in the source tree app to configure the ssh keys. There are no ssh key management options in the preferences&settings.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

849 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you