Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

When running the Sourcetree install in Windows 10, the install window will not display

OS: Windows 10 Home Edition

Sourcetree version:  2.5.5

Hello,

When I try to install Sourcetree, the window that appears is blank.  I have tried uninstalling Sourcetree via the remove programs feature from the control panel, deleting the related Sourcetree folders/files located in the C:\Users\XXX\AppData\Local\Atlassian but whatever I do, the window is always blank. 

How can I install Sourcetree given the situation? 

Have attached a screenshot of what appears when I try to install Sourcetree.Sourcetree install problem sceenshot.jpg

Cheers,

David

1 answer

0 votes
Ana Retamal Atlassian Team Jun 11, 2018

Hi David, could you try the suggestions on the thread Sourcetree transparent windows and see if they work for you?

Let us know!

Kind regards,

Ana

Hi Ana,

Thanks for the guidance.  I followed the instructions for changing the registry and Sourcetree is displaying correctly now.  The steps i took are as follows:

 

1- Go into windows registry (search for regedit)

2- In the registry editor, find: HKEY_CURRENT_USER\Software\Microsoft\Avalon.Graphics

3- Right click the Avalon.Graphics folder, select New then select DWORD

4- The name of the new entry needs to be: DisableHWAcceleration

5- After creating the new entry, right click and select Modify

6- In the Modify screen, change Value Data to 1

7- Open up Sourcetree again and it should display correctly

What this new registry entry does is disables hardware acceleration for WPF apps.  To be honest, i'm not sure what a WPF app is but Sourcetree is one of them.

 

regedit add dword.pngFor other people who may encounter a similar issue, here is a screenshot for how to edit the registry:

Like andrea.nguyen likes this
Ana Retamal Atlassian Team Jun 14, 2018

Thanks for sharing your solution with the rest of the Community, @David Tang :D

Have a nice evening!

Ana

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,390 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you