Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,305
Community Members
 
Community Events
168
Community Groups

Sourcetree: transparent windows in Windows 10 Pro

Edited

Hello at all,

Sourcetree somehow stopped working on my Windows 10 Pro laptop. Everytime I start the application (or the installer), I see a transparent window (see attached screenshot below). The sourcetree.log has only some of the following entries, no stacktraces or further details. 

ERROR [2018-06-05 17:18:09,721] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied  

 

I tried several sourcetree versions (2.5.5, 2.4.8.0, 2.4.7.0) and none of them are working anymore (for some reason, my sourcetree installation worked well until I started my laptop today). I use Windows 10 Pro (10.0.16299.371). Laptop restart and several installations / deinstallations did not work. 

 

I found two other posts which also describe this problem, but I found no fix for the problem:

Link1

Link 2

 

I highly appreciate any ideas how to fix this issue.

Thanks and best regards

Ben

 

sourcetree.png

3 answers

1 accepted

6 votes
Answer accepted

Disabling hardware acceleration for all WPF apps did the trick. Seems like there are some issues with the video drivers.

Set the following registry key to a DWORD of 1:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

This is definitely the right solution. Thanks. Your answer saves my time. 

If there is no key in that location, create one. 

This is right solution. 

For this problem, I once gave up using SourceTree even though I love it.

I guess hundred thousands of (windows) users are suffering from this problem.

You saved my life. Thanks a lot.

Thanks a lot, it worked perfectly!

0 votes
Mike Corsaro Atlassian Team Jun 08, 2018

Hello! There's a few things you can try:

  • Make sure your video drivers are up-to-date
  • Try running Sourcetree in compatibility mode
  • Try running Sourcetree with overridden high DPI settings

Do you have any other apps that have this behavior? Are you using a high-contrast theme or anything like that?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events