Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree: transparent windows in Windows 10 Pro Edited

Hello at all,

Sourcetree somehow stopped working on my Windows 10 Pro laptop. Everytime I start the application (or the installer), I see a transparent window (see attached screenshot below). The sourcetree.log has only some of the following entries, no stacktraces or further details. 

ERROR [2018-06-05 17:18:09,721] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied  

 

I tried several sourcetree versions (2.5.5, 2.4.8.0, 2.4.7.0) and none of them are working anymore (for some reason, my sourcetree installation worked well until I started my laptop today). I use Windows 10 Pro (10.0.16299.371). Laptop restart and several installations / deinstallations did not work. 

 

I found two other posts which also describe this problem, but I found no fix for the problem:

Link1

Link 2

 

I highly appreciate any ideas how to fix this issue.

Thanks and best regards

Ben

 

sourcetree.png

3 answers

1 accepted

6 votes
Answer accepted

Disabling hardware acceleration for all WPF apps did the trick. Seems like there are some issues with the video drivers.

Set the following registry key to a DWORD of 1:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

This is definitely the right solution. Thanks. Your answer saves my time. 

If there is no key in that location, create one. 

This is right solution. 

For this problem, I once gave up using SourceTree even though I love it.

I guess hundred thousands of (windows) users are suffering from this problem.

You saved my life. Thanks a lot.

Thanks a lot, it worked perfectly!

0 votes
Mike Corsaro Atlassian Team Jun 08, 2018

Hello! There's a few things you can try:

  • Make sure your video drivers are up-to-date
  • Try running Sourcetree in compatibility mode
  • Try running Sourcetree with overridden high DPI settings

Do you have any other apps that have this behavior? Are you using a high-contrast theme or anything like that?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,353 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you