View whole stash in SourceTree

When viewing the changes in a stash in SourceTree, some of the files changed don't show all changes.  How can I view (within SourceTree) all of the changes?

4 answers

Try to remove the index on the file, then add the index again.

It's only showing the first hundred lines of files that have been deleted or added.  I found editing the "Max Diff Line Count" (I put it arbitrarily large to 10,000 instead of stupidly small default of 100) option in Tools -> Options -> Diff fixed it.  But it still doesn't show the full contents of added/deleted files.

stash.jpg

can you attach  a screenshot to understand your question better?

I believe this is a limitation in windows version, you have the option to open it in an external tool from within sourcetree.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

274 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot