Unable to create .git/index.lock File exists.

I use sourcetree on Windows 10.

I can't stage files after upgrade to 1.9.6.

So i did downgrade to 1.9.5.

How can i solve it?

 

8 answers

Having exact same problem on same OS, same version. Error appeared today after update.

First I though it was git problem, so I updated embedded git, tried using system git, still no progress. Will let you know if have any news

Same versions, same problem here as well.  Rolling back to 1.9.5 resolved the issue.

Any time this error appears in SourceTree, I've confirmed that the file in question does not exist and I am unable to remove it to resolve the issue per advice found elsewhere.  

Same problem here. Version 1.9.5 on Windows 10 Anniversary Update works fine; no startup crash, either, for me. It doesn't seem to be a git problem, since the command line is still working fine. 

Also, duplicate question: https://answers.atlassian.com/questions/39580090 

Before the upgrade to 1.9.6 I have had this error for about half of my operations. Now it is systematic. Anybody knows which version of source tree actually works?

This is very very annoying, every updates come with new bugs, please stop releasing bad releases, just test them before asking everybody to update or people will just leave your soft forever ... seriously that's very unprofessional.

Another release full of bugs... 
Same problem here.  

switched to GitKraken - problem solved

https://www.gitkraken.com/

A workaround is to use the "No staging" interface. (I personally prefer the "Split view staging".

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

844 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you