Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,975
Community Members
 
Community Events
168
Community Groups

Trouble getting authentication when fetching

I am trying to fetch from our repository but it keeps prompting me to input my password and saying that the username/password is incorrect. I've reset my password and also have tried using both my email and my username in the popup box so I know that information is correct. I also have Oauth set up as well so it shouldn't be prompting me to log in anyways. What can I do to fix this? Thanks.

1 answer

0 votes
bgannin Atlassian Team Aug 31, 2018

Hi Kellan,

We need a few more details to help debug this situation:

1. what OS are you on?

2. what version are you using?

3. what hosting service is the account for?

4. what is the authentication configuration for the account and repository (they can be independent, i.e. - OAuth + SSH or U/P + HTTPS)

Brian Ganninger
Senior Mac Developer, Sourcetree

I'm on windows 10. Using Sourcetree version 2.6.10.0 trying to pull from bitbucket. And I'm using HTTPS + OAuth. Let me know if you need anything else. Thanks!

Any update on this? It's critical because I can't work with the rest of my team.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

78,687 views 134 29
Read article

Atlassian Community Events