Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Terminal not opening

Simon Dupras
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 30, 2015

I just installed Source Tree on Windows 8.1, opening the terminal doesn't works. Neither the button in the ribbon, or actions or pressing shift+alt+T, opens the terminal.

 

What can I do to fix this ?

30 answers

23 votes
Mark Kuijer
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 8, 2020

I have the same issue.
as a workaround I changed the used 'git verison' 
options --> git --> git version
from 'emmbeded' to 'System'
now I got a terminal again

jagraham777
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 9, 2020

This worked for me.  Thank you!

Like Litovchenko Vladislav likes this
max.santos
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 10, 2020

Worked for me. I'm current using Sourcetree version 3.3.6

Thanks Mark

Like Litovchenko Vladislav likes this
Dushan Nanayakkara
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 14, 2020

Worked for me after updating installed git to the latest version( 2.25.0.windows.1). Source tree version 3.3.6

Like # people like this
MKr January 15, 2020

Will try that -- BUT I really don't feel comfortable with it because of the potential of (sometimes subtle) incompatibility problems between an otherwise installed GIT and Sourcetree (which is one reason why Sourcetree brings its own, so it will 'fit').

Please Atlassian, make the Terminal button work again.

Like # people like this
Tanny
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 13, 2020

selecting 'System' works only with git version 2.25.0 (maybe above later on).

keitoro
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 19, 2020

This worked, should be fixed soon. 

Lander Vanhaverbeke March 16, 2020

This workaround is not working for me. 

Bo_Chen
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 7, 2020

thanks, it works. 

Caio Campos April 12, 2021

Weirdly enough, I had to do the opposite 🤷‍♂️

Like # people like this
Deleted user May 17, 2021

What's a stupid bug.

I also had to do the opposite downloading another Git version (embedded) that I don't need on my computer.

Support doesn't care for more than 5 years as usual.

 

 

Like Leszek Pietrzak likes this
7 votes
Anthony Hugo
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 7, 2020

Same problem - 3.3.6 help please?

5 votes
MKr January 13, 2020

Tried 3.3.7 -- same problem.  In fact, the latest version that could open the terminal for me was 3.2.6 (to which I just have downgraded (again)).

jhensonWV
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 27, 2020

Downgrading to 3.2.6 was the solution for me too. Really frustrating as 3.3.6 was working and randomly died on me. 

Windows 10

Like # people like this
Jon Jowett
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 21, 2020

Same issue on 3.3.6-3.3.8 (Win 10 64bit). Downgrading to 3.2.6 was also the solution for me.

Like Matthew Jones likes this
Matthew Jones
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 9, 2020

Thanks @jhensonWV, downgrading to 3.2.6 worked for me too.

I like Sourcetree, but nearly every time I update it, something goes wrong.

Previously, I've had issues such as OK and Cancel buttons doing the opposite thing to each other, another time it had a memory leak, which made Sourcetree unusable, and now this problem with terminal not working.

I'd like to be able to recommend Sourcetree to other developers, but every update is a gamble.

Like # people like this
maxshuty
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 31, 2020

Same issue here, thanks for providing the last stable version that didn't have this bug. Here is the download to 3.26 from Atlassian (for Windows):

https://product-downloads.atlassian.com/software/sourcetree/windows/ga/SourcetreeEnterpriseSetup_3.2.6.msi

5 votes
Onur Er January 3, 2020

Same problem in the year of 2020!!

Version 3.3.6

Please fire millennials!

4 votes
Dushan Nanayakkara
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 13, 2020

Same issue with Version 3.3.6.

Switching between embedded and system git versions didn't help.

4 votes
MKr January 13, 2020

Same problem here with 3.3.6...

3 votes
tun min aung
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 17, 2020

Same problem with 3.3.6

3 votes
MKr January 13, 2020

Tried 3.3.7 -- same problem.  In fact, the latest version that could open the terminal for me was 3.2.6 (to which I just have downgraded (again)).

3 votes
ocelot_pl
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 27, 2017

I also had the same problem with SourceTree 2.3.1.0 and Git 2.14.1 - Git bash not started correctly for existing repositories.

I've added Git folder to the environment's PATH, but this didn't solved the problem, next I uninstalled and installed again SourceTree (didn't help)

So i created an empty repository and... terminal worked correctly with it.
Then I copied existing repository into the newly created repository (overwrote all files) and... terminal started correctly (why it didn't work before? I don't know). It looks like and internal SourceTree's error.

And now is the best: I removed all repositories from SourceTree and instead Add command I dragged and dropped them again into SourceTree and... terminal window started working correctly.

Brian Merrell
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 24, 2018

This worked for me, as well.

I removed my bookmarked repo and tried adding it back using the Add button and dialog. The terminal command did not launch anything.

Then I removed the bookmarked repo again and tried adding it back by dragging the folder into my repo folder. Then the terminal command started working.

Version 2.4.7.0

Like RJ Howell likes this
RJ Howell
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 26, 2019

I had this problem, too.  

Drop and Add worked for me, too.  Thanks, Brian.

Karl Baum
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 13, 2019

I'm having the same issue.  What is the "my repo" folder you are able to drag the folder containing the repo onto?

Brian Merrell
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 13, 2019

The folder is the organizational folder within SourceTree.

2 votes
Terry Coley
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 7, 2020

Same problem - version 3.3.6

2 votes
MKr February 3, 2020

Just tried the newest version 3.3.8 -- still NO LUCK.  Please, Atlassian, repair the Terminal-Button...

2 votes
jphwth
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 29, 2020

Same here, 3.3.6, win10 64, tried everything suggested in this thread and it didn't work so I'm downgrading the version

2 votes
timlegrand March 29, 2016

Note that SourceTree does not start the terminal when not in a repository (e.g. fresh install, no repo yet).

To enable the terminal, either:

  • open an existing repository ;
  • or create a new dummy repository : "Clone / New" / "Create New Repository" then click on the terminal button. You can safely delete the dummy repository after that.
1 vote
Steven_Chang
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 21, 2020

Interestingly, I just installed 3.3.8 on a new computer and the terminal opened fine with the embedded Git. However, the problematic one on my other computer still couldn't open the terminal after an update. I have too many projects in bookmark and settings are too complicated to afford a clean reinstallation. Maybe someone can teach me how to do so as I may still need that one day.

Steven_Chang
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 21, 2020

Finally, I found this post

https://community.atlassian.com/t5/Sourcetree-questions/Terminal-button-in-SourceTree-fails-to-launch-a-terminal/qaq-p/113865

The solution works for me. I am on 3.3.8.

Cite here

- Updated SourceTree to 3.3.8
- Updated Embedded Git
Disabled "Use Git Bash as default terminal" in "Tools->Options->Git"
- Starting Terminal now launches command prompt
- Restart SourceTree
- Enabled "Use Git Bash as default terminal" in "Tools->Options->Git"
- Starting Terminal git bash now works

Like # people like this
Sean Duvall May 4, 2020

I was having the same problems w/ the terminal window.

I was able to get it working again. by only updating the embedded Git version.  (Under Options > Git > Git Version pane > Update Embedded.

I was using Sourcetree 3.3.8 as well.  It may be that the extra steps you mentioned, aren't required.

Like Peter Brinkhuis likes this
Peter Brinkhuis
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 13, 2020

Updating the embedded version and restarting SourceTree worked for me as well.

1 vote
Deleted user March 17, 2016

Same problem with 1.8.2.11, Windows 7 64-bit.

1 vote
Deleted user March 1, 2016

We have the same Problem with the new Sourcetree version 1.8.2.3.

Win7

1 vote
Andrew Chester
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 17, 2016

I, and others in my team are seeing the same problem as Chris.

For the record - the terminal button opens git-bash by default, and you can manually open it by running the corresponding executable. If you are using system git on windows the default location should be C:\Program Files\Git\git-bash.exe. 

1 vote
Chris Wright
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 17, 2016

We're having the same problem here as well, it seems to be a little random, and some people have found that it suddenly started working again, but we don't know what caused it to start working either (theory that changing from "Use System Git" to "Use embedded Git" fixed it doesn't seem to work and was the only real lead we had).

We're on Windows 7 64-bit, SourceTree 1.7.0.32509, and Git-2.7.0-64-bit.Also have Tortoise Git installed (1.8.16.0-64bit).

1 vote
marcandredoucet
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 5, 2016

We are three developpers to have the same behavior here! Is someone have a solution?

0 votes
AgnaktoreX
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 6, 2021

Downloading and updating to Sourcetree 3.4.4.0 + updating embedded Git to 2.30.2 solved the problem for me

0 votes
purushothamck
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 26, 2021

Actually, it was "Options -> git -> System" selected in my case which was not opening the terminal. I changed it to embedded, sourcetree then downloaded the git and installed it.  Afterward, it started working fine. 

0 votes
Jordan April 23, 2021

Same problem with 3.4.4.

0 votes
haniball hanj
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 20, 2021

I have this problem for a year plus

0 votes
david.klempfner April 18, 2021

Same problem with v3.4.3.

0 votes
Lander Vanhaverbeke April 14, 2021

I have a workaround for this issue. The same workaround also seems to resolve all other issues I had with Sourcetree:

 

  1. Uninstall Sourcetree
  2. Install Fork
Caio Campos April 14, 2021

🤣

Caio Campos April 14, 2021

Unfortunately, Fork doesn't seem to support Azure DevOps yet?

haniball hanj
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 20, 2021

I can confirm that this solution works. Funny, sad but true...

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events