Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,549
Community Members
 
Community Events
176
Community Groups

Still can't connect because of 'unable to get secret' error

Edited

Hello,

I already discussed my problem in a comment in a similar post, but no reply came, so I start a new post.

I can't use Sourcetree to connect to Bitbucket for a month now, even though I used it for two years without a problem.

When I click 'Refresh OAuth Token' I get a 'Confirm Access' page on my browser, then an 'Authentication successful' page. Then, I get the following error in Sourcetree

2020-01-14 08_59_51-Edit Hosting Account.png

I have tried the following:

  • Deleting all Sourcetree passwords from Windows Credential Manager
  • Revoking OAuth authentication from my BitBucket account
  • Reinstall Sourcetree
  • Different browser
  • Connecting with Basic authentication using a different account I have. Even though the password was correct, I still couldn't connect.
  • Closed live protection from my antivirus (Malwarebytes Antimalware)

Any help provided would be greatly appreciated!

 

EDIT: Added more fix attempts

 

 

4 answers

1 accepted

4 votes
Answer accepted

I have the same problem.

Hello, I have th esame problem. Did you find the solution?.

Like angelonikolaou likes this

Nothing yet. I basically switched to a different tool.

Hi. I have this issue too. What too did you switch to?

I managed to make bitbucket work by switching back to version 3.3.9. Haven't updated since. Try that

I had the same issue this morning. I now know what happened, so let's see if my case is helpful for you.

Here is what I had to do to solve this (following that order):

  • Updated to the latest SourceTree version
  • Validate that your TLS 1.2 is activated. On Windows 7, you will have to edit the registry with regedit (you can find easy steps on internet)
  • You have to update your Embedded GIT as well. Go in Tools -> Options -> Git -> Press the button Update Embedded (at the bottom). You shouldn't see an SSL error here anymore.
  • Once this is done, I went to the Authentication dialog pointed out here and I could successfully "Refresh OAuth Token". 

Simple remark: I updated my SourceTree from a really old version (1.x to 3.3.8). In previous version, TLS 1.2 wasn't mandatory. Also, I'm running on Windows 7 and TLS 1.2 isn't enabled by default. It may not fully be your case, but those steps could cover your problem as well.

Now it's working!

Finally!

I had the same issue this morning. I now know what happened, so let's see if my case is helpful for you.

Here is what I had to do to solve this (following that order):

  • Updated to the latest SourceTree version
  • Validate that your TLS 1.2 is activated. On Windows 7, you will have to edit the registry with regedit (you can find easy steps on internet)
  • You have to update your Embedded GIT as well. Go in Tools -> Options -> Git -> Press the button Update Embedded (at the bottom). You shouldn't see an SSL error here anymore.
  • Once this is done, I went to the Authentication dialog pointed out here and I could successfully "Refresh OAuth Token". 

Simple remark: I updated my SourceTree from a really old version (1.x to 3.3.8). In previous version, TLS 1.2 wasn't mandatory. Also, I'm running on Windows 7 and TLS 1.2 isn't enabled by default. It may not fully be your case, but those steps could cover your problem as well.

Now it's working!

Finally!

Excellent info, thanks - worked for me.

Exelente !! Muito obrigada, funcionou para mim.

not work for me, any other solutions?

Same problem here

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events