Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree on OSX not working after enabling Two Factor Authentication

I updated my Bitbucket account to 2FA. Now I can no longer Push files using Sourcetree. I get the errors: 'Authentication Failed' & 'Invalid Username or password'.

Following the suggestions of other posts, I updated Git to the latest. Still no luck. 

Does anyone have any ideas? This is my system:

OSX ver: 10.14.3

Git (neither work):

Internal: 2.20.1

System: 2.21.0

Sourcetree: 3.1.1 (213)

thanks

1 answer

1 accepted

0 votes
Answer accepted
bgannin Atlassian Team Mar 25, 2019

Hi @Chris Goane,

Please try the following and let me know if it works out or fails.

1. Switch to "Embedded Git" (2.21.0 is not verified yet with ST)

2. Remove your Bitbucket Cloud account in Preferences -> Account

3. Re-add your account (optionally restart ST beforehand, shouldn't be necessary) 

Our apologies for the hiccup.

Brian Ganninger
Principal Developer, Sourcetree

Yes, this worked like a charm. BTW, my System Git is 2.21.0.

 

Thanks for your help.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,261 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you