Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Sourcetree keeps crashing after launch


I recently added a new repository to my Sourcetree and it keeps crashing. It is also now showing a new tab with my user id that doesn't link to any real repository.


Version: 3.1.3

Windows Logs: Sourcetree Error Logs 5.21.19

I've successfully had multiple repositories cloned in Sourcetree in the past and all the files in this new repository were previously saved in another repository cloned in Sourcetree. I also successfully committed the files in this repository when I managed to get the app to work for long enough without crashing. 

I also tried going through all the steps in this post, reinstalling the app and deleting all the suggested files in my AppData folder but am still seeing the same issues.

1 answer

1 accepted

5 votes
Answer accepted

Turns out this was related to this issue.


I was able to resolve by changing the settings on my user directory by searching "file explorer options" and selecting "Show hidden files, folders, and drives" under the 'View' tab. I then deleted the .git folder from my user directory and my Sourcetree is no longer crashing.

God bless you... this solved my issue after wasting an entire afternoon.

Like # people like this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events