It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree keeps asking for login and password...

Wojciech Borczyk Apr 15, 2012

23 answers

2 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

22 votes
Answer accepted
Steve Streeting Apr 15, 2012

The Apple Keychain actually requires a username to be known in advance for the password lookup to work; if you don't include a username in your URL then SourceTree remembers the last username that was used to successfully log in to a given host and tries that one by default to look up the keychain entry. This can, however, be unreliable if you don't use the same username all the time on a given host. To make it unambiguous, include the username in the URL, like this:

http://username@host/path/to/repo

How was this even accepted?!! That didn't help and won't help.

Like # people like this

Thanks. It worked. This is the correct anwser. No need to run pull on the terminal. In my case is simple as editing the repo URL and include my user as you mention, BEFORE the host. After that I restarted SourceTree and problem solved. The same applies for each new repo. Thanks! :)

Culbert Zhang Jan 29, 2018

I use code.aliyun.com for git trusteeship, then the sourcetree says "Password Required For user git on host code.aliyun.com". After I changed the url to "https://username@code.aliyun.com", the problem solved.

Shrinath Kopare Feb 19, 2018

You can change the URL from 'Repository -> Repository Settings... -> Remote -> Edit'.

Like # people like this
Priyanka Bardhan Feb 26, 2018

For me, after including username and putting the URL "https://username@code.aliyun.com" , it is still asking me for the password.

Like # people like this
Alyssa Nguyen Mar 09, 2018

Not only did this not help, but it broke things even further, making it impossible to do anything with the remote.

Like Sarah Mohammed likes this
Amit Kumar Dubey May 02, 2018

That worked for me, Thanks!!

Siya Ntombela Jul 22, 2018

This didn't work for me. I'm using v 2.7 on Mac

Like Elnur Gasanov likes this
Ben Baker Sep 27, 2018 • edited

@Trung Vu 's Use system GIT within SourceTree's preferences solved the issue.

 Appears to be using an older version of GIT: 2.10.1, instead of 2.17.1

 

OSX 10.11.6, SourceTree Version 2.7.6 (177)

Like # people like this
Paulo Oliveira Oct 12, 2018

Worked wonderfully! Thank you.

Clint Anderson Oct 24, 2018

After months of just putting up with this issue, and hours spent trying to get it working again to no avail, @Ben Baker's suggestion solved my problem. 

Jan Vrabel Nov 08, 2018

Use system GIT also solved this problem for me. Even when system git was in use -> switched to embedded and back to system, same version, same git, but it works now

Like # people like this
Chao Feng I'm New Here Jan 19, 2019

Google and tried for several hours, USE SYSTEM GIT is the only way works for me.

rafael perez melendez I'm New Here Mar 19, 2019

@Ben Baker 

has the only working solution so far... it shouldn't be a comment

21 votes
Answer accepted
Ana Retamal Ortiz Atlassian Team Apr 05, 2019

Hi everyone, this is Ana from the Community Support team!

We’re seeing several recent responses saying that the solutions provided here do not work. This post originated in 2012, so whatever was valid at that time doesn’t necessarily need to be valid now. There could also be different reasons why Sourcetree is asking you for credentials, so there isn’t really a unique answer.

To make sure we’re helping everyone, I’ll be closing this thread now. If you encounter this issue now and the solution provided here doesn’t help you, please submit a new question and make sure to add the following:

  1. If you’re using Sourcetree for Windows or Mac
  2. Which operation where you performing when you were prompted for your credentials
  3. Provide a screenshot

Thanks and see you around :) 

Ana

79 votes
Albert Khabibullin Nov 30, 2017

1. go to terminal in your project folder

2. 

git config credential.helper store

3. 

git pull

 4. input your username and password

Curtis Melaroo Dec 20, 2017

This is the only thing that worked for me. Thanks Albert.

Like # people like this
A E Dec 25, 2017

+1 THANKS!!

Like # people like this

This works for  me. Sourcetree 2.7 

Not real Developer Jan 30, 2018

This works for  me. Thanks!!!

Siya Ntombela Jul 22, 2018

This is the only solution that worked for me. Using sourceTree 2.7 for Mac. Thanks!

Toby Horn Jul 31, 2018

Everything else above failed to work, this worked perfectly though, thanks!

Kenneth Requina Aug 07, 2018

This worked for me

Peter Willand Aug 08, 2018

The only one solution, that worked for me.


SourceTree ver.: 2.6.10.0
System Git ver.: 2.18.0 + git-lfs v2.4.2
Win 10 Pro 64bit 

Thanks!!!

Nicolas Milcoff Sep 13, 2018

This worked for me (macOS). Thanks!

huizhang Oct 10, 2018

This works for  me. +1 THANKS !!!

Umang Savaliya Oct 29, 2018

Worked for me.

Dhruv Aggarwal Nov 04, 2018

Thanks ,

 

Worked for me as well

Charne Fourie Nov 07, 2018

This was the only solution that worked for me. Thanks so much!

Fabrizio Masini Nov 09, 2018

this is the real good solution.

Especially because, in case you don't have https support in your server, you cannot just switch to it...

Thank you very much!

Ataer Caner Nov 11, 2018

Simple, correct answer. Thank you!!

Keen Foong Nov 12, 2018

This one has been plaguing me for months. Thank you!

Anish Kumar Dec 10, 2018

This worked for me. SourceTree 3.0.1 on macOS

Tarashor Dec 10, 2018

+

Radhouane Bouazizi Jan 02, 2019

Well done, That is perfect.

Is that a bug ?

Michael Dmitriev Jan 07, 2019

thank you!!!!!

Wing Chin I'm New Here Jan 08, 2019

This worked!!

powellian Jan 30, 2019

Nice one! Worked simply/easily for me and - based on the upvotes and other people it worked for - this should be the accepted answer.

hong nhan nguyen Feb 24, 2019

This worked for me, Thank you!

rafael perez melendez I'm New Here Mar 19, 2019

This also works!, looks like the only one that doesn't work is the accepted one :p

Faizy Ahmed Mar 19, 2019

This really worked for me after so much wasting effort on other solutions. Thank you so much Albert!

Source Tree: 3.1.1

Xcode: 10.0

28 votes
Owen Peng Feb 23, 2015

I have same problem and troubled me for a long time, now I found a solution.

1. go to terminal in your project folder.
2. run #git pull
3. input your username and password
4. go back to sourceTree and run Fetch or Pull, it does not ask your password again.

Björn Harmen Gerth Jul 09, 2015

This worked for me too

Björn Broer Aug 26, 2015

Amazing! Thanks for this, it works like a charm. After doing the Git pull command in Terminal, the next time you fetch, pull or push, it asks to allow Keychain to be accessed by Sourcetree, and when clicking on "Always allow" you don't have to enter your password anymore!

Khalid Merhi Oct 05, 2015

Thanks for the tip - this solved my issue as well!

Jason Harlow Feb 23, 2016

Thanks for pointing this out - totally worked.

Aryo Pinandito May 16, 2016

This solution is only working on Terminal. @Steve Streeting solution is working for me, SourceTree 2.2.4, Mac OSX 10.11.3 El Capitan

Thomas Chuntic Oct 18, 2016

Thanks

Seungbeom Roh Oct 25, 2016

Thank you!

Trung Vu Nov 08, 2017

I tried but no success, but then I figure out:

- SourceTree use Embedded Git service

- Terminal use System Git, which I install via XCode

 

So, I just need to update SourceTree config via "Preferences -> Git tab -> Git Version" by select "Use System Git", then everything works well

Don't forget run steps as @Owen Peng suggest above. good luck

Like Tom Nguyen likes this
Minh Huynh Nov 26, 2017

Thanks @Trung Vu

It's totally working with your solution.

"I just need to update SourceTree config via "Preferences -> Git tab -> Git Version" by select "Use System Git", then everything works well"

Ajit Jan 25, 2018

Thank you so much @Trung Vu !!

 

Updating  SourceTree config via "Preferences -> Git tab -> Git Version" by select "Use System Git" works for me.

Brian Sexton Jul 10, 2018

@Trung Vu's solution worked for me.

Vinh Tran Aug 08, 2018

thanks @Trung Vu it's worked for me.

j c Aug 21, 2018

Helped in my case. Thx!

Fawad Tiemoerie Dec 01, 2018

Helped me. Thank you!

Hrvoje Drinovac Dec 01, 2018

This works!

Thank you... I almost went crazy!

12 votes
Darren Muff Aug 04, 2017

This has been bugging me for ages. I have an answer that now works for me on SourceTree V2.6 (123).

First go to keychain and remove any bitbucket entries (you may not have to do this but it helped me to work out that sourcetree had actually entered something)

Under sourcetree->preferences go to Accounts

Click edit

Change Auth type to "OAuth" from Basic

Click on "connect account"

login to the bitbucket page from the pop-up window

Make sure protocol is 'HTTPS'

Hit 'Save'

Bring up one of your git repos and pull it from bitbucket.

The first time it will ask if it can access keychain. Hit 'Always Allow'

You should then have pulled the repo.

Check in Keychain access to see if there is a new entry called 'Bitbucket Credentials'

If you have this then sourcetree should not ask you for your bitbucket password in future.

Time will tell if this keeps working. Good luck.

Brian Farrell Aug 26, 2017 • edited

OH SWEET JESUS!  After searching about this problem for over an hour and trying several different fixes, this is the one that FINALLY WORKED for me.

I had previously set-up two-factor authentication for Bitbucket and tried using an 'App Password', but that was not good enough. I couldn't make the repeated auth requests stop until I switched from 'Basic' authentication to 'OAuth', as Darren suggested.

I am running SourceTree 2.6.2 on Mac OS Sierra 10.12.6

Sanity Restored.

Thanks, Darren!

Like Darren Muff likes this
Ethan Beyer Aug 28, 2017

After a previous reply that said I had fixed this with System Git, I was still prompted over and over for BB creds.

Darren's solution seems to be working though!!

Like Darren Muff likes this
James Furey Sep 22, 2017 • edited

Woo-hoo!

Thank you, thank you, thank you.

Cheers, @Darren Muff!

🎉

Note: I had to make sure the protocol was set to 'HTTPS' before logging in from the pop-up window.

Like Darren Muff likes this
Adam Mendoza Oct 18, 2017

  🔥 yup, that solved this issue for me. 

Like Darren Muff likes this
Ethan Beyer Dec 01, 2017

I keep getting emails about how other people solved this, and smh, @Darren Muff still has the only answer that worked for me. I'd upvote it more if I could.

Like Darren Muff likes this
7 votes
Paw Baltzersen Jan 05, 2017

Crazy that this is still an issue after so many years, but I ran into this today. The fix was to install git on the computer and use that instead of the embedded version. After a git pull and entering the credentials there I can now work in SourceTree without it asking for password all the time.

Johannes Katelaan Mar 01, 2017

This worked for me, too. Thanks!

Aditya Panchal Jul 17, 2017

Tried so many other solutions, but this is the only one that worked for me.

Ján Marcin Oct 16, 2017

Thank You! All I had to do was switch from Embedded to System Git.

4 votes
Tom Brückner Jun 26, 2017

This is driving me MAD. Every once in a while, typically after some obscure update, SourceTree on MacOS starts to require my password on any push or pull action. Sometimes it works for months, then suddenly, I have to type in my password again. This is so strange. What is causing this, and why can't they fix this once and for all?! I am really considering to switch to GitKraken now.

Ethan Beyer Aug 24, 2017

+1

3 votes
Thomas Scheelhardt Jun 27, 2017

We are seeing this eaxct problem for two accounts on our Team and it seems Atlassian have no clue what is going on, since they choose not to offer an answer to this crippling bug.

We have tried all the suggested 'fixes' but none have worked.

A source control system that you cannot access is not only completely worthless it is also endangering projects.

Atlassian how about you actually address this matter, since by your own account you are now comitted to provide support via the community.

Tom Brückner Jun 27, 2017

For me, setting the Git client to "System Git" has solved the problem for now. But I have no clue why this has to be done once in a while. And until then, I already have forgotten that this setting is available. It's a shame that remembering the password does not just work out-of-the-box. This is such an essential feature, especially if you're using long, cryptical passwords, as I do. Always having to open your password manager is pretty annoying.

Thomas Scheelhardt Jun 27, 2017

Yeah if it was only an inconvenience it wouldn't be quite as bad, however we have users that are denied access to their account after a while of having the 'Ask for password every time' issue.

So basically the problem escalates from an annoyance to a complete blocker.

Simone Scarduzio Jul 30, 2017

Thanks @Tom Brückner setting "System Git" solved my issue for now.

Ethan Beyer Aug 24, 2017

Setting Sourcetree to use System Git worked for me as well.

If I HAD to guess, I would imagine this error is permissions-based. If the copy of Sourcetree tries to read the keychain value for bitbucket, and can't, then it needs to continually ask.

When changing to System Git, since it's apart of the user's path, I think it actually triggers the system to display the dialog box asking for permission.

Again, at any rate, using System Git and running `git pull` worked for me.

Like Chris Ellepola likes this
1 vote
Mike Lebon Feb 26, 2017

I was running into the same issue and then realized that my SSH agent did not have my SSH keys loaded.  So make sure that you have your SSH key loaded if that's how you are talking to your git repo server.

See here for more details of how to check you agent and see which keys are loaded:  https://confluence.atlassian.com/bitbucket/set-up-ssh-for-git-728138079.html

Also see this if you discover that your keys are not loaded at startup/login on macOS Sierra:

https://blog.elao.com/en/tech/ssh-agent-does-not-automatically-load-passphrases-on-the-osx-sierra-keychain/

 

Hope that helps

1 vote
Pavan Kalyan Tolety Apr 19, 2017 • edited

Remove all other authentications section in sourcetree other than git hub.

Then click Add or either go to Hosted repositories(to quickly check if it was successful) and click on edit accounts.

In credentials select OAuth and select refresh token. You will be redirected to bitbucket website and click on Grant access.

Now goto your fresh account in sourcetree and select Set as Default.

Done. Now you should see all your repositories in hosted repositories. It shows login error if it is not successful

1 vote
Darren Dickerson Apr 20, 2017

This is still happening.  Strangley it seems that if there are many differences SourceTree flakes out and tries to authenticate.  You should be able to duplicate this by say coping a version of a project that has CR/LF windows style line endings but the repository has Linux style line endings.  Removing the windows style line endings stopped SourceTree from trying to authenticate.

0 votes
Wojciech Borczyk Apr 15, 2012

Sourcetree keeps asking me for login and password when pulling from external git or mercurial repository. I've tried different things:

- removing keychain entry: no result

- reinstalling sourcetree: helps, but the bug re-introduces itself soon and then until next reinstall it is still there.

During single pull it asks for password always two times. Adding user name to connection stirng helps in the form, that it remembers user name but still asks for password.

0 votes
Anton Trapp Jul 10, 2013
Same thing here. Every day when I start Sourcetree and try to access a remote location (username IS included) sourcetree deletes the keychain entry and after that it tries to access the entry (which was deleted some milliseconds before). Keychain for bitbucket than contains the new entry (bitbucket.org). If I quit Sourcetree and start it again (the same day) it is working with the keychain entry. One day later, same problem.
0 votes
Mikkel Lund Nov 23, 2013

I have the same problem as Anton Trapp. Has a solution been found?

0 votes
Dmitry Maslov May 11, 2014

I had the similar problem. Every fetch/pull/push action requires password from my github account. I found the answer for this problem here
https://answers.atlassian.com/questions/219115/changing-password-in-source-tree-1-6-1-mac-13<br< a="">>

It helped :)

0 votes
Christian Giordano Mar 31, 2016

Check in your settings in the Bitbucket account. On mine it was using https, I put ssh and all fine now.

0 votes
Dale Swift Mar 01, 2018

Using ssh connection but always prompted for a password. If I enter the password several times push does work but the password is never saved.

For me the solution was a bit more obscure.

By default ssh will always check for ~/.ssh/id_rsa and attempt to use that for any connection. In my case that id is not relevant for git, but is used for ssh to a different server.

The solution is to add a an entry in ~/.ssh/config which tells ssh to only use password.

Add the following lines:

Host myhostname
PreferredAuthentications keyboard-interactive,password
0 votes
Enes Acikoglu Mar 13, 2018

Use stable version 2.6.3 to get rid of this problem.

link :https://www.sourcetreeapp.com/download-archives

0 votes
Christopher Morris Apr 12, 2018

I just changed my password is it is no longer asking me for my password every few minutes.

0 votes
RajanandP Oct 18, 2018

Came across this same issue and multiple posts too. So consolidated my research and fix at one place https://stackoverflow.com/a/52884626/5107365. Summary is, problem solved when I used the same password for Atlassian's account address(which is the Gmail ID I used to OAuth to my bitbucket user), as that of my Gmail ID.

0 votes
Antão Almada Nov 02, 2018

I don't understand why there is a seemingly great accounts feature but still get keychain pop-ups...

0 votes
Jagadeesh Dec 10, 2018

Hi,

I too faced the same issue and got resolved.

Please follow below steps to resolve.

Source Tree -> Tools  -> Options -> Updates -> Click on 3.0.12.2543 for update

Source Tree -> Tools  -> Options -> Git -> GitVersion -> Click on Embedded and Update Embedded buttons.

Restart source tree and it works fine.

Amen Asli I'm New Here Mar 05, 2019

same worked for me 

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

376 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you