It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree keeps asking for bitbucket password on windows

Joseph Moore Aug 20, 2015

password I enter on Sourcetree is correct and works for a few minutes but then i get asked to reenter it. And yes I tell it to remember the password. this started happening after I updated to the most recent version and wow is it annoying. 

39 answers

32 votes
Chandramohan Nataraj Mar 06, 2018

Guys, Please try this as well. SourceTree is having the Embedded version of Git. By default, SourceTree will not use System installed Git, instead it will be using the embedded git. This credential-cache problem will not be there in latest Git version. I'd suggest to upgrade your embedded git version of sourcetree and configure sourcetree to use system git instead of embedded git.

How to do that? 

1. In SourceTree, Navigate to Tools > Options > Git

2. Look for the Git Version section

3. Observe what version of Git System has and What version of Git embedded in sourcetree

4. Switch to the system git version (if that is latest)

5. Once done, restart the sourcetree and try again the login, this time it will not ask you again

Dulon Zaman May 16, 2018

I was having the same problem having upgraded to SourceTree 2.7 from 2.6 on Mac OS High Sierra and this solution finally solved my issue (I didn't even have to log out of SourceTree)

Ivan Gasparetto Jun 29, 2018 • edited

This is the right answer for the problem. I am on Windows

Ramanan Shanmugam Jun 29, 2018

Great.. perfect solution for my problem..

George Schizas Jul 12, 2018

I have the same problem and I've always used the System Git, not Embedded Git.

I have even removed the BitBucket account completely from the accounts (Tools > Options > Authentication) and Windows' own credential manager (Control Panel > User Accounts > Credential Manager > Windows Credentials)

git 2.18.0 (system), SourceTree 2.16.10

This seems to be something else entirely (my guess would be the "registration")

Like # people like this
Andrey Jul 18, 2018

This is not work for me (git 2.18.0 (system), SourceTree 2.16.10). I've also tried to remove credentials from source tree and windows account manager, but "bitbucket login" window still appears every several minutes (even after I entered right password or refresh auth token sucessfully (green sign)

Like Jule- likes this
Jesús González Jul 20, 2018

I was having the same issue explained here, bitbucked / atlassian credentials were not been saved, so smartgit kept asking for email and password.

image.png

This started when upgraded to git 2.18.0 ... What I had to do was to reinstall git without "git credential manager" (I unchecked when asked during isnstallation).

image.png

 

Now smartgit launched atlassian user / password once when I pulled, I introduced it correctly and never asked me again.

Manuel Zavatta Aug 07, 2018

thanks!

Bil Simser Aug 07, 2018

tried both embedded and system git (latest version) with sourcetree 2.6.10.0. Nothing working. This is ridiculous since it actually worked yesterday. Since then I've reset my password (just to be sure), logged out and back in again in the browser and that all works (so I know the password is right). I even did the OAuth authentication (again) and got it all green, still the atlassian dialog keeps coming up and won't let me log in (giving me an authentication error). Yet I can bring up the list of repos but just can't clone them or pull down the latest version. WTF.

Bil Simser Aug 07, 2018

Update: Got it fixed. While looking around at other questions I came across this one about https authentication (I tried SSH, app password, etc. as I struggled for the last couple of hours trying to get this to work).

https://community.atlassian.com/t5/Sourcetree-questions/How-to-update-HTTP-S-credentials-in-sourcetree/qaq-p/297564

If you're using HTTPS and are getting the atlassian dialog with no luck (even though you're SURE you're using the right password) this worked for me. Delete the passwd file in the AppData folder then pull the code down.

You'll get the atlassian password dialog again, but after entering the password correctly, you'll get the bucket dialog asking you to update your password. Enter it again and you should be set, at least that worked for me.

Frankly the combination of SSH or app passwords or HTTPs combined with bitbucket vs. atlassian is a mess. Maybe if you pick on approach and only use that it'll work all the time but I mix and match repos and authentication based on the sensitivity of the data, so maybe that's my problem. However I just find it not intuitive when things break. The error message from the OAuth that came up (or whatever it was) when the atlassian dialog came up said there was a problem with the username/password, except there wasn't.

Hope that helps. Back to coding...

Like # people like this
Martin Ninov Aug 07, 2018

But.... what if I have NO CODE to pulldown?

I have NO repositories and NO accounts remembered for bitbucket!

I am on windows with git 2.18.0 and Sourcetree 2.5.5.0.

 

The program has literally NO REASON to ask me for my Atlassian account, apart from it being made by them.

Demian Hartmann Aug 15, 2018

I have the problem as well. And not a single solution works. On my other computer it usually accepts the password after a few tries but on my laptop nothing works. And I have to work. I will probably change to another program since this problem persisted for a while now. 

Like Dan Yin likes this
Gabriele Coppola Sep 14, 2018

Using SourceTree, Bil Simser solution worked for me when all the others didn't. I Found passd file on C:\Users\User\AppData\Local\Atlassian\SourceTree

Like # people like this
Juraj Kovac Sep 30, 2018

Mine works after switching from Embedded to System Git. I would've never guessed this myself, so thanks to everyone!

Atlassian, you need to make this right!

This worked for me as well

Rafael Braga Dec 02, 2018

I removed Git 2.17 that was installed, downloaded Git 2.19.2 and didn't install the GCM. Still no luck.

So I updated the embedded version and start using it. I deleted all my credentials from windows credential manager and re-authenticated again using OAuth. So far, so good. This is a mess. All of my coworkers had this same issue, and each one of them solved it in a different manner. 

keith garry Dec 02, 2018

Using SourceTree, Bil Simser solution worked for me when all the others didn't. I Found passd file on C:\Users\User\AppData\Local\Atlassian\SourceTree

Like Wojciech Kulik likes this
Nagaraju Bussa I'm New Here Dec 06, 2018

This solution worked for me. Thank you!

Kamil Poznakowski Jan 01, 2019

Worked for me. I'm on Windows.

Siddish Pai Jan 15, 2019

Thanks..
Working solution.... :-)

Keith Austen Mar 17, 2019

Updating the Embedded GIT version worked for me - thank you.

12 votes
Wiaan Oosthuizen Jul 05, 2018

Hey Guys, i found the solution..

uninstalled sourcetree.. 

problems went gone.

Frank Hutchings Sep 04, 2018

:D

haha XD

rajendra I'm New Here Jan 03, 2019

lol.. I am also going to do the same. www.skydevelopers.net

9 votes
Jack Sinclair Feb 22, 2016

This worked for me (i'm on Windows).

Go to View > Show Hosted Repositories > Edit Accounts > find the relevant account and click 'Edit' > Change Password.

Hopefully it works for some other poor souls out there!

Claudio Delgado Aug 23, 2016

Thanks! It worked for this poor soul out there! laugh

sherif darwish Mar 06, 2017

Thanks, This worked for me as well.

3 votes
Mike Walters Sep 14, 2015

I am having the same problem. I noticed it when I upgraded to Windows 10. I can't say for sure it's because of the upgrade to the OS.

 

For what it's worth, I can get it to stop temporarily by clicking the "Show hosted repositories" icon at the bottom left when you open source tree. Then "Edit Accounts", click the account and "Edit", then "Change Password".... It will eventually drop the password again. It's incredibly frustrating, and I am about to drop sourcetree and possibly Bitbucket due to this, if its not fixed.

Max Pixel Jul 24, 2016

Same problem here! It's infuriating.

Ericc Feb 12, 2018

Me too... :-(

GOH JIN JIE Sep 06, 2018

same

3 votes
Neville Attard Feb 12, 2016

I started having this problem too when I upgraded to SourceTree 2.1 and yes it's very annoying

(I'm on El Capitan 10.11.2)

Dmitry Savchenko Oct 29, 2017

try using OAuth with connect account

3 votes
Logan Rhodehamel Jul 18, 2018

Every time SourceTree asks me if I would recommend to a friend, I think about how many times I have to log in over and over and over before I answer. How can a basic thing like remembering credentials be so broken?

Rafael Braga Dec 02, 2018

I used to give a 10/10 reply every time. Now I just look at that survey and think the exactly same thing...

Nithya Rajendrababu I'm New Here Dec 13, 2018

I can no longer get into my account... its broken

2 votes
Torsten Dec 08, 2016

Sourcetree seems to have some problems importing old config files from a previous Version.
Changing stuff in "Edit Accounts ..." / Hosted Repositories seems to make Sourcetree rewrite some of it and solves the Problem.
Also try to change the preferred Protocol... that did the trick for me.

 

First time and ~a year ago I had this problem I started deleting Stuff in C:\Users\%username%\AppData\Local\Atlassian\SourceTree  

I cant remember exactly what I did back then, but I think deleting Accounts.json (and reentering the data in Sourcetree) worked.

 

bas Sep 15, 2017

I also resolved the problem by removing the map:

C:\Users\%username%\AppData\Local\Atlassian\SourceTree  

2 votes
zeev glaizer Feb 18, 2017

same problem, windows 10. tried everything.., HELP!!!!

2 votes
Dener Rocha Aug 19, 2017

I use windows insider and have same problem still....ask login, ask login, ask login...!

2 votes
James Naylor Feb 22, 2018

Same problem here on Win 10, Sourcetree 2.4.8.0. I've treid all of the suggestions here and the password prompt still pops up all of the time. It's incredibly frustrating.

Tom Hivert Feb 25, 2018

Same here, I have tried everything and updated to latest version, can't use sourcetree atm

Martin Wiingaard Mar 06, 2018

Me too!

Chandramohan Nataraj Mar 06, 2018

@James Naylor - Please try my detailed suggestion given below. Update git version used by sourcetree 

2 votes
Joseph Moore Jul 17, 2018

wow, almost 3 years later And I have been having this problem on and off... Atlassian. I have been patient. Get it together and fix this nonsense. You are supposed to help with software development not make it frustrating.

2 votes
Ryan Chapman Nov 13, 2018

SourceTree is no longer functional as it periodically fills my screen with login windows. Atlassian - please provide an expected date for a fix or describe a workaround that works. Thanks.

1 vote
Anders Jul 07, 2016

I have the same problem connecting to Visual Studio Online.

1 vote
Michael McGee Jan 12, 2017

I removed my user name in authentication tab and then pulled, got prompted for the password and I clicked the box that says save the password on the prompt and then it worked..

1 vote
松尾 修 Jun 12, 2018

my enviroment v2.6.6.0 (windows 7 32bit)

Atlassian login popup dialog always on desktop!

i updated git version.

now ... dialog popup going ...

1 vote
jboy flaga Jul 02, 2018

This is what I discovered (after searching for 'sourcetree' in my drive C:):

  1. Uninstall SourceTree
  2. Delete folder C:\Users[username]\AppData\Local\Atlassian\SourceTree
  3. Delete folder C:\Users[username]\AppData\Local\SourceTree
  4. Reinstall SourceTree

This helped me! Thank you.
I've tried lot's of things but removing "/AppData/*" is the only useful action.

0 votes
David Trudeau Feb 03, 2016

Having the same issue, anyone find a solution?

0 votes
ionescu manuela Jul 25, 2016

After tthe Sourcetree last upgrade in MAY I can't log in Sourcetree anymore -  I'm on Windows 8.

I've done everything, but I coldn't find an answer. 

I've tried Go to View > Show Hosted Repositories > Edit Accounts > find the relevant account and click 'Edit' > Change Password.

The system aproves my Atlassian PWD but gives an error message after. "Please enter your Bitbucket/GitHub username" . 

But from June "Atlassian account is coming to Bitbucket!" - eveyone has received this mail, so it's supposed to be only one account for all the Atlassian app.

How can this bug be solved, anyone found a solution?

 

 

 

 

0 votes
Max Pixel Jul 26, 2016

I'm in a conversation with a support rep about this, and it sounds like it's caused by not having an explicit username in the url for your repository. Unfortunately, for private subrepositories, that's just not an option.

0 votes
jeffrey Jan 05, 2017

This did not fix the problem for me. I click "show hosted repos" and nothing ever loads in the window. I added my Bitbucket account info, again, for the 15th time, and Sourcetree is still asking me to authenticate. Pathetic. For now, I'll revert to version 1.8

0 votes
Paw Baltzersen Jan 05, 2017

The fix for me was to install git on the computer and use that instead of the embedded version. After a git pull in cmd and entering the credentials there, I can now work in SourceTree without it asking for password all the time.

0 votes
Adeem Salik Feb 23, 2017

Asking password again and again since i changed my credentials from Atlassian site. I reverted my credentials back to old ones and pull and push work fine without asking password but sourcetree still asks password for nothing (2 times if i cancel).

0 votes
Zlatko Stapic Oct 06, 2017 • edited

The same problem when updating to 2.3.1.

It helped to me to delete bitbucket account in Tools -> Options -> Authentication and then to edit %AppData%\Local\Atlassian\SourceTree\passwd (in Notepad++) and to delete any unused/wrong username password pairs. 

After deleting one for bitbucket it stopped asking for password.

refalm1@gmail.com Aug 14, 2018

Thanks, that worked for me 👍

Rabishan Maharjan Aug 20, 2018

worked for me too

0 votes
Thibault L Jan 30, 2018

on macOS High Sierra 10.13.3 I changed the authentication mode from SSH to OAuth to Basic / HTTPS and it worked.

Christian Snijder Apr 25, 2018

This saved my day.

0 votes
Andrey Borisko Apr 25, 2018

had the same. it wasn't really source tree issue, but i fixed it by removing httpusepath = true line

from: 

> git config --global --edit

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

1,969 views 14 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you