Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,366,916
Community Members
 
Community Events
168
Community Groups

Sourcetree - can't push login problems

Edited

I was doing regular commits in Sourcetree and successfully pushing each commit to remote.  Suddently, on an attempt to do a commit, Sourcetree popped up a login box.  I entered my Atlassian credentials but the push to remote in Sourcetree failed with the message "Invalid username or password".

I was puzzled as I hadn't done anything to change my login credentials.  I opened my browser and, using exactly the same credentials, I was able to successfully log into id.atlassian.com and was also able to successfully log into bitbucket.org (and able to see all of my repositories).

I restarted my computer, opened Sourcetree, and again attempted to do the push but got exactly the same error: a login box, followed by a failed login message in Sourcetree.

I then used Git Bash to try to push the commit to origin using the command: git push origin <branchname>.  An Atlassian login box appeared, I entered exactly the same credentials as I had entered into the login box when trying the push from within Sourcetree, and the push succeeded.  To make sure, I opened my browser, logged back into bitbucket.org, opened my repository, and the commit was there.

Any ideas on how I can resolve the Sourcetree error, or what else I can do to try to identify the cause of the error?

 

1 answer

1 accepted

2 votes
Answer accepted

I found the following solution posted by David Keck:

https://community.atlassian.com/t5/Sourcetree-questions/How-to-update-HTTP-S-credentials-in-sourcetree/qaq-p/297564

David's solution is to simply delete the file called 'passwd' from:

C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree

Then restart Sourcetree.  When you next do something that requires accessing the remote (eg, a push or fetch), Sourcetree will prompt you to login and will recreate the passwd file with your credentials.

David's solution worked for me.  Thank you David.

Thank you this helped me as well

Didn't work.  I'm getting "Logon failed, use ctrl+c to cancel basic credential prompt.  error: unable to read askpass response from ...Askpass.exe"  :-(

Thanks,

Tien

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events