Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Sourcetree can't pull/push login problems

I am updating bitbucket through source tree but it stopped allowing me to push/pull with the same problem:

remote: Too many invalid password attempts. Try logging in through the website with your password.


I have gone to the Accounts section and re-connected in SourceTree and I have gone to the bitbucket and Atlassian website and logged out and logged back in.


I need to fix this ASAP as I can't access the project



4 answers

1 accepted

4 votes
Answer accepted
Ana Retamal Atlassian Team Jun 15, 2017

Hi Anton! Can you try resetting your Atlassian password using this link

After that, log in again to with your email and password (make sure NOT to use the Google login). You may be asked to go through a captcha screen. Once you get logged in properly to, you can try pull/push again and let us know if it works. If it still doesn't, can you:

  • Attempt performing pull/push using the command line? Is it successful?
  • Tell us whether you're you using HTTPS or SSH?

Best regards,


Like Gethin Taylor likes this

You save my life! Thank you very much

You saved my literally!!

Hey mate,

I followed same steps but no luck! Still its asking me for credentials and even upon entering correct details also its saying as wrong.


Could you please help me on this.

Like Jessica Rodriguez likes this

Hey ana ,

i tried to reset my password and then login to bitbucket and tried to  push it from source tree, still m not able to push. its still saying invalied username and password, though every thing is right. 


please help me out.


thank u

Like Gary Mckelvy likes this

I have the same issue as Malaka.

I did all the password reset stuff, logged on from my development box, BitBucket push asks for authentication but it fails.

Like Ole Gunhildsberg Hansen likes this

Popup of authentication confirmation is displayed indefinitely.

I'm having the same issue with SourceTree on a repo that was working before. All of a sudden I started to get this error when trying to push/pull 

 remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

I had also see the erorr above before that:

 remote: Too many invalid password attempts. Try logging in through the website with your password.

I tried what it said and I could log into the atlassian and bitbucket website just fine. I also reset my password to be sure to the same previous password.

From Source Tree I was also able to successfully refresh the oAuth to bitbucket from sourcetree. That works fine and succeeds and then I can see the list of repositories in source tree.

However, When I try to push/pull from a previously cloned repo or try to clone a new repo that is listed in source tree (from successful OAuth to Bitbucket) then I get the error:

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

Now I consistently get this error. Please let me know if you know how to solve this issue.

Ana Retamal Atlassian Team Aug 14, 2017

Hi Gaurav, there's an existing thread regarding this issue at Authentication issues. Some members of the Community have shared the solutions that worked for them, there are 3 available solutions right now:

  • Delete the Windows Credentials stored in Windows (that's where SourceTree stored them), delete the passwd file, then restart SourceTree. To see and remove them, do the following:
    • Open the Control Panel and click on User Accounts.
    • In the left hand list of links, click Manage Your Credentials. When it opens, it shows your Web Credentials.
    • Click the Windows Credentials "button". This shows your stored Windows credentials. Look for entries that start with "git:http" and include your server name and/or user name and remove them.
  • Go to Repository > Repository Settings, selecting my repository, and changing the username from my old Bitbucket username to my Atlassian account's email address. Then, following your original advice to remove the passwd file, I was able to successfully pull.
  • Download SourceTree version from our website and install it. Reject the upgrade to 2.1.10 that comes up.

I hope this works for you! If it doesn't, my recommendation would be to post your answer in the original thread.



Hi Ana

Downloading the version solved the problem.


Tried all that still getting the same error can anyone help.Trying to clone a repository

 remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

I ran into the same problem but my solution ended up being updating my password in Accounts. I got to Accounts by going to the SourceTree splash screen, clicking on the gear icon, selecting Accounts and editing my login information to update my password.

I realized this when I was able to push through command line and it asked me for my password, then pushed no problem. The odd thing is I changed my password a few weeks ago and the issue just caught up to SourceTree. Seems like a big lag from changing the password to it being an issue in SourceTree.

I keep having the same issue, and when I go to accounts i see this error 

failed to get user details for user [DomiDenie]

You do not have permission to access URL ''. The request returned with status code 'Unauthorized'


Anyone have a solution for this? 

I have the same issue with Sourcetree 3.0.15.

I have two development boxes (A and B). I can push, pull from B, but I can't PUSH from A.

I tried the password reset solution, but it didn't solve the issue on A, which is annoying, but the scary one is that I can still pull/push from B using the old password!!! (I mean without being asked to log in again)

I haven't yet deleted the password file - where is that?

I tried installing older versions, but the zip files in the download archive don't contain installables. Am I missing something?

sourcetree is not working with bitbucket on windows 10

can not push or pull

I have desktop PC and laptop, the Desktop PC SourceTree works fine, but laptop keep failing on password when I pull/push. Because of using the SourceTree everyday and worry about reset password will potentially stop my desktop SourceTree, I reinstall SourceTree for my laptop 

I check the "Generic Credentials" for the laptop, missing "git:".

1. I remove all the "" related items from "Generic Credentials",

2. Install "SourceTreeSetup_3.3.8.exe".

3. "Registration" , press "Bucket" icon, it launch browser with "Authentication Successful",  the button "Next" never active, so I can't go further for installation.

4. I can use browser to view my repositories on "".

What's wrong with me?



Suggest an answer

Log in or Sign up to answer

Atlassian Community Events