It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree 2.1.10.0 Authentication Issues

Dean Kinane Aug 11, 2017

I updated to version 2.1.10.0 today and now I can't perform any git operations with SourceTree.

I get the error:

Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

I have opened Tools>Options>Authentication and ensured my credentials are valid. I've tried using Basic and OAuth and in both cases SourceTree says "Authentication OK" but I still get the error when trying to push or pull.

Is anyone else experiencing this issue?

 

12 answers

16 votes
Sean Winstead Aug 11, 2017 • edited

I upgraded to 2.1.10 just now and have not yet encountered an authentication problem.

When a person at our office encountered a credentials problem, for a release prior to 2.1.10, the solution that worked for us was to delete a file named passwd located in AppData\Local\Atlassian\SourceTree.
 
My passwd file was zero bytes in length. His pwd file did have content and, after he deleted it, he could authenticate.

Before deleting the passwd file, we had tried the following with no success:

1. Re-entering credentials through the UI provided by SourceTree

2. Deleting the Windows Credentials stored in Windows by SourceTree.

Amnon Aug 11, 2017

I'm afraid that didn't work for me. It did prompt me for my password, but after I've entered it the problem recurred.

Sean Winstead Aug 11, 2017 • edited

The only other thought I have is to delete the Windows Credentials stored in Windows, delete the passwd file, then restart SourceTree. We had deleted the credentials before deleting the passwd file, and I am not sure if the problem was rectified by deleting the credentials and file, or deleting only the file.

Following is what I wrote down regarding the Windows Credentials. We are using Windows 10.

SourceTree stores credentials in the Windows credential manager. To see and remove them, do the following:

  1. Open the Control Panel.

  2. Click on User Accounts.

  3. In the left hand list of links, click Manage Your Credentials.

  4. When the Manage Your Credential page opens, it shows your Web Credentials. You can see that selected at the top of the page.

  5. Click the Windows Credentials "button". This shows your stored Windows credentials.

  6. In the list, look for entries that start with "git:http" and include your server name and/or user name for Atlassian Stash.

  7. Remove the entries.

Laszlo Apro Aug 11, 2017

Worked for me! Thank you very much, Sean!
Cheers

Thomas Larsen Aug 11, 2017

Thanks Sean!  Deleting the passwd file and removing the credentials in credential manager worked for me, too.

Josh Oh Aug 11, 2017

For anyone using VSTS + SourceTree, I was able to follow Sean's instructions upto where SourceTree prompted me for the password. It failed to take my credentials because VSTS disabled my existing credential due to too many failed auth attempts (made by 2.1.10.0).

At this point I had to go into VSTS > Code > Clone > Generate Git Credentials and create a new password.

I entered my newly generated password on the SourceTree prompt and it allowed me access.

Sean Winstead Aug 11, 2017

That is a really good point. We use Atlassian Stash (an old version of Atlassian BitBucket Server). When dealing with the credential issues, sometimes the operation in SourceTree failed due to too many failed logins. The git error messages shown by SourceTree did not make this obvious.

It was only the error messages shown by the Fetch operation that told us Atlassian Stash needed the user to verify they were human via Captcha. So we had to navigate to the user's detail page in Atlassian Stash and click the Clear Captcha button.

Sameer Argade Aug 14, 2017

Didn't work..

Amnon Aug 14, 2017

So I was able to sort it out just now, by going to Repository->Repository Settings, selecting my repository, and changing the username from my old Bitbucket username to my Atlassian account's email address. Then, following your original advice to remove the passwd file, I was able to successfully pull.

Thanks!

John Rempel Aug 16, 2017 • edited

This (deleting the passwd file) worked for me. Thank you.

Deleting the password file worked for me. Thank You!

Matthew Duguay Aug 22, 2017

Thanks! This worked for me:

Close SourceTree

Delete Windows Credentials

Delete passwd file

Reopen SourceTree

Login when prompted

Bill Langton Sep 26, 2017

Same process listed by Matthew D, worked for me as well.

passwd file is in located in AppData\Local\Atlassian\SourceTree.

Leunam Dec 13, 2017

You are my hero dude!

Pedro Mota Aug 07, 2018

Version 2.6.10: this works for this version, thank you very much!!

Clément Duquesne Aug 09, 2018 • edited

For me as well on 2.6.10, thank youuu (deleted pwd file & windows credentials)

Gibran Massabni Dec 01, 2018

Sean!!! ... it worked for me to  in version 2.3.1.0!! Many thanks for the solution!! I lost 4 hours trying go solve it! ... and I would lose some more without your solution. Tks again!

8 votes
Dean Kinane Aug 14, 2017

Hi all

According to Atlassian this is an issue with the version of Git Credential Manager that's bundled with the software.

If you go to Tools>Options>Git>'Update Embedded Git' it should fix the issue for in version 2.1.10

Hope that helps.

Cory Strischek Aug 14, 2017

This worked for me. SourceTree 2.1.10.0 on Windows. BitBucket authentication. I only encountered the issue on Push. 

Randy Edwards Aug 14, 2017

This worked for me as well.  SourceTree 2.1.10.0 on Windows.  Bitbucket authentication.  I encountered the issue on fetch and pull.  -- Thanks a bunch for the post.

Sameer Argade Aug 14, 2017

Didn't work, planning to reinstall the latest version, a bit frustrating

Sameer Argade Aug 14, 2017

Sorry it was update embedded git and after the update use embedded git that worked for me, thanks for the update.

Reem Hourieh Aug 17, 2017

At first I removed passwd located in AppData\Local\Atlassian\SourceTree and this solved the sourcetree issue but I was still not able to pull or push using command line or any other git tool until I did this one as this update seems to have messed up my git.

Marco van Swelm Aug 23, 2017

This worked for me. Thanks Dean!

Sergio Gastón Man Oct 26, 2017

La solucion a mis problemas..

 

Tools>Options>Git>'Update Embedded Git'

 

THANK YOU

Tim B Nov 24, 2017

This was the solution for me as well with Sourcetree Version 2.3.5.0

Pedro Mota Aug 07, 2018

Version 2.6.10: don't work for this version

1 vote
Kirsten Greed Oct 05, 2017

I still have the issue after installing SourceTree  2.3.1.0

I am trying to update the Embedded Git.  Now I have a new Issue Unable to extract Portable.Git.7z This file is open as [PE] Archive

Kirsten Greed Oct 05, 2017

I closed source tree, and a few login dialogs that were beneath the window I closed.  Then I re-ran Update Embedded Git and finally it worked.

0 votes
brian tweed Aug 11, 2017

Having the exact same problem. Re-installed Souretree, declined the 'would you like to upgrade to 2.1.10' and everything works again.

sven boogaart Aug 11, 2017

Do you lose all your settings? I have setup some ppk connections etc and dont like reinstalling them. Where did you get a previous version?

0 votes
Peter Blomqvist Aug 11, 2017

I got the same problem after upgrading to 2.1.10.

But I downloaded SourceTree again (version 2.1.2.5) from their web and installed that version. After that I don't have any problem with the authentication. I rejected the upgrade to 2.1.10 that came up...

0 votes
Amnon Aug 11, 2017

Seconded (or is this fourthed at this point?). Updated to 2.1.10, and nothing works.

Tried refreshing the OAuth token through the options, but although the operation was successful, nothing changed.

0 votes
Kirk Aug 11, 2017

Downgraded to version that is on the website. Started working again.

0 votes
David Friedrich Aug 11, 2017

I just had the same issue. I deleted the passwrd file and it solved the problem

0 votes
Kirsten Greed Aug 19, 2017

Where do I find the password file?

0 votes
Brian Cullinan Nov 09, 2017

Still getting this error.  This is awful.  I get multiple login popups constantly throughout the day.  Like source tree or Git is not saving my information at all.

0 votes
Didou Schol Dec 18, 2017

I was about to kill myself over this. Only thing that worked in the end was removing the passwd file located here:

AppData\Local\Atlassian\SourceTree

and restarting SourceTree. It asked for the password and it worked.

0 votes
Bill Langton Mar 20, 2019

Just ran into this AGAIN with V3.1.2. 

Fix for me:  Tools > options > Git, then Update Embedded.

Push again after update, was asked for pwd.  was ok after that.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

3,366 views 3 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you