It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree will no longer start Edited

Mel Pettitt Sep 18, 2017

SourceTree on my workstation was recently updated - currently version 2.3.1.   Although I didn't explicitly update it, I know it was updated because the icon changed on my task bar.

Now, since the last reboot, when I try to start SourceTree, nothing happens.

Looking into sourcetree.log, the following is logged:   (As you can see it's getting a NullReferenceException and quitting)

What do I do?

Thanks, in advance, for any help you can lend.

Mel

 

( I've edited this point 3 times now to update things, and now it says SPAM??  Really?  It is NOT spam.   I need a resolution to this problem. )

--------------------

ERROR [2017-09-18 20:25:41,868] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-09-18 20:25:41,968] [1] [SourceTree.App] [OnStartup] - Failed to start
System.NullReferenceException: Object reference not set to an instance of an object.
   at SourceTree.Notifications.NotificationsManager.SetOwner(NotificationDialogWindow notificationWindow)
   at SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](NotificationDialogWindow notificationWindow, Tuple`2 customAction, VistaTaskDialogIcon icon)
   at SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](String title, String message, Tuple`2 customAction, String cancelLabel, String suppressionSetting, Action`1 suppressionChangedAction, Object contentControl, String contentCommandLabel, Action contentAction)
   at SourceTree.Notifications.NotificationsManager.ShowNotificationDialogWithYesConfirmation(String title, String message, String details)
   at SourceTree.Configuration.WpfSpellCheckerPreFlightCheck.Run()
   at SourceTree.AppRoot.RunPreFlightChecks()
   at SourceTree.AppRoot.OnStartup(StartupEventArgs e)
   at SourceTree.App.OnStartup(StartupEventArgs e)

2 answers

1 accepted

11 votes
Answer accepted
Mike Corsaro Atlassian Team Sep 19, 2017

Hello! This is a known issue. Please navigate to the config file location (C:\Users\{USERNAME}\AppData\Local\Atlassian\SourceTree.exe_{RANDOM_GUID}\2.3.1.0\user.config) and find the following line:

<setting name="AutomaticallyCleanUpDictionaryFiles" serializeAs="String"> 
<value>True</value>
</setting>

 

Make sure that value is set to True

Mel Pettitt Sep 20, 2017

Thanks!   I added this and the problem went away.

Tan Luong Van Sep 25, 2017

After I added this line it worked. Thank

John O'Toole Sep 27, 2017

I had the same issue - I couldn't get SourceTree 2.3.1.0 to start even after doing a full clean install.  

The "AutomaticallyCleanUpDictionaryFiles" line wasn't in my user.config.  I added it and now I can open SourceTree. 

Dan Haywood Oct 01, 2017

Another +1 on this (Windows 10 Pro + ST 2.3.1.0) ... had to add the line and then it worked.

Graham Mueller Oct 10, 2017

I added this and the application opened again, but when I returned to the user.config file, the lines I added were removed by SourceTree again... am I going to have to keep setting this? Why is it getting cleared?

Markus Weser Oct 11, 2017

Thanks! Adding this setting solved for me (Win 10 16299.15, SourceTree 2.3.1.0) 👍

Nik P Oct 12, 2017 • edited

Worked for me. But guys, please fix this problem. I just wasted about 1.5 hours trying to find the solution.

untit1ed NA Oct 12, 2017 • edited

Worked for me. 

0 votes
Ana Retamal Ortiz Atlassian Team Oct 18, 2017

Hi everyone! As an update for this topic, we have just started the progressive rollout of Sourcetree v2.3.5.0 which includes a fix for this issue. You should be prompted to upgrade sometime over the next 14 days or, alternatively, you can download the update directly from https://downloads.atlassian.com/software/sourcetree/windows/ga/SourceTreeSetup-2.3.5.0.exe

Cheers :)

Ana

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

1,950 views 14 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you