Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,687
Community Members
 
Community Events
168
Community Groups

SourceTree: suppressConflictWarnings fix on a Mac

Edited

Hi -

I'm using SourceTree 3.2.1. I must have inadvertently clicked to suppress merge conflicts on a Mac because they're not showing up anymore. I found the answer to update the user.config in the AppData folder (https://community.atlassian.com/t5/Sourcetree-questions/Conflict-dailog-does-not-display-I-tried-to-edit-the/qaq-p/798376) on Windows but in my Mac I check here:

~/Library/ApplicationSupport/SourceTree.

There's no user config, only my cert, browser.plist, hgrc_sourcetree, ImageCache folder and openWindowList. None of which appear to have this property.

Where should I be looking to show the merge conflicts again. Any tips are greatly appreciated.

1 answer

1 accepted

0 votes
Answer accepted
bgannin Atlassian Team Jul 02, 2019

Hi @Matt Ganz,

Run the following command in Terminal:

defaults remove com.TorusKnot.SourcetreeNotMAS suppressConflictsWarning 

and then launch the app. That removes the preference value entirely, restoring you to the default (no pun intended.) 

Cheers,

Brian Ganninger
Principal Developer, Sourcetree

Where do I have to be? Whether I run this command from my home directory or Library/Preferences (where the com.TorusKnot.SourcetreeNotMAS is located) I get the following error: 

 

Domain (com.TorusKnot.SourcetreeNotMAS) not found.
Defaults have not been changed.

Are you sure it's not defaults delete....instead of remove? This deletes the domain. Or even this: 

defaults write com.torusknot.SourceTreeNotMAS suppressConflictsWarning 0
bgannin Atlassian Team Jul 02, 2019

That also works :)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events