Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Conflict dailog does not display, I tried to edit the SuppressConflictsWarning but can't find it

I've seen posts on where the config file is to set the SuppressConflictsWarning

But when I open the config file the setting is not there

Seriously if you can click on a check box to nut show this dialog again (and why would anybody even want to do this?) then there should be something in the settings to turn it back on

1 answer

0 votes
minnsey Atlassian Team May 17, 2018

Hi

On Sourcetree for Windows the setting is written to the user.config file.

It can be a bit tricky to find, it will be under the following folder

%localappdata%\Atlassian\Sourcetree\Sourcetree.exe_url_{hash}\{version}

where {version} matches the version of Sourcetree you are running and then you are looking for this:

      <setting name="SuppressConflictsWarning" serializeAs="String">
        <value>True</value>
      </setting>

and you want to set it to False.

Please read my posts more carefully:

"I've seen posts on where the config file is to set the SuppressConflictsWarning

But when I open the config file the setting is not there"

the xml

      <setting name="SuppressConflictsWarning" serializeAs="String">
        <value>True</value>
      </setting>

Does not exist in that file, should I add it?

minnsey Atlassian Team May 17, 2018

It is possible you have found a bug.

Checking that checkbox in the dialog, should set the SuppressConflictsWarning = true and it will only be persisted across re-starts if it is saved to the user.config, The default is SuppressConflictsWarning = false.

You can add that
entry to the user.config and that should force to show (false) or not (true)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,333 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you