It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree startup SpellChecker error

Since the last update to 1.9.10.0, SourceTree on startup displays the following error:

"SourceTree detected the following invalid Dictionary file references. These are known to cause performance issues. Do you want to remove these invalid dictionaries?"SourceTreeSpellCheckerError.png

No file references are actually displayed. I've clicked both Yes and No multiple times on startup, but each ensuing startup displays the same error message.

I've disabled spell checking in the Tools-Options, which hasn't helped. I've looked in the SourceTree install directory but see nothing resembling dictionaries that might be susceptible to editing. Any other ideas welcome.

8 answers

I've had the same problem for about the last couple weeks.   Didn't really cause any trouble, just caused me to have to dismiss the dialog.

But today, it has started crashing on startup instead.

As best I can tell (from the sourcetree.log file), it's getting a NullReferenceException exception while trying to call ShowNotificationDialogWithYesConfirmation method in Source.Configuration.WpfSpellCheckPreFlightCheck.Run().

I've tried deleting the custom dictionary (RoamingCustom.dic).   That did nothing.

So now SourceTree is totally unusable.

I don't understand this bug. What does office have to do with Sourcetree?

Seeing this issue in version 3.3.6.

 

Any Fix?

there seems to be more information here, but sadly no workaround... I'm seeing the same issue

http://stackoverflow.com/questions/41486308/spellchecker-error-source-tree

I have the same issue.  Was hoping they already solved it.  Error started with the 1.9.10 update.  I hit Yes and go on just fine.

I looked in the log
(\users\YOURLOGIN\AppData\local\Atlassian\SourcceTree\sourcetree.log)

My problem was the custom dictionary C:\Users\sjsobol\AppData\Roaming\Microsoft\Office\16.0\d668cc87\Proofing\RoamingCustom.dic

After deleting it, I ran SourceTree and actually saw the path to the .dic file listed in the Invalid Directories dialog. Clicked yes, problem was gone.

That was a few minutes ago. Don't know when/if it's going to start again, but I have some thoughts:

  • Office can use the custom dictionary with no issues
  • For SourceTree to be relying on an arbitrary data file created by Office is a pretty heinous hack (IMO)
  • The dialog popping up with no dictionaries listed is an obvious bug, and Atlassian knows about it, they've known about it for a while and haven't fixed it,
  • and while I <3 SourceTree, I find it highly irritating that this hasn't been fixed. It doesn't impact usability, it's just annoying, but it'd be nice if it did get fixed.
  • Also, SourceTree shouldn't try to load the dictionaries AT ALL if I turn off the "spell-check commit messages" feature, but I did that and still had this problem. Really, guys?

I have exactly the same issue but I do not want to remove the Custom dictionary. I also do not have the spell-check turned on so technically there is no reason for SourceTree to use it.

Any other ideas?

Any fix for this bug, yet? 

Experiencing it for months now on a Spanish locale Windows 10.

Related info: https://stackoverflow.com/questions/41486308/spellchecker-error-source-tree

Whenever I add new words to a Spanish dictionary in Office Word, SourceTree keeps complaining.

I unchecked the option "Spell check commit" under tools > options as commented here: https://community.atlassian.com/t5/Sourcetree-questions/After-updating-to-1-9-9-20-I-get-an-invalid-Dictionary/qaq-p/166944

 

But problem remains whenever I open SourceTree.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,910 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you