After updating to 1.9.9.20, I get an invalid Dictionary notification every time I start up, but it doesn't list any "invalid" files

The dialog says:

SpellChecker Error

SourceTree detected the following invalid Dictionary file references.  These are known to cause performance issues.

<Empty list>

Do you want to remove these invalid dictionaries?

I click "Yes" every time, and it still comes back the next time I start up.

10 answers

1 accepted

9 votes
Mikael Sandberg Community Champion Dec 07, 2016

If you un-check "Spell check commit comment" under Tools > Options it will go away. May or may not be the intended functionality in order to bypass Windows’ own spellchecker performance issues.

I had to un-check it, restart (the message was displayed again), re-check it, and restart again (the message was NOT displayed).  Thanks!

I am experiencing the same issue. The error message goes away if I disable spell checking of my commit comments, but the message comes back when I re-enable spell checking. I would like to keep spell checking enabled. Does anyone know any other workarounds?

I am experiencing the same issue. It seems like every update introduces a new bug, you guys need to get it together.

I'm also having the same issue with it.  I would also like to keep my spell checking on.

This did not work for me either. Certainly, disabling the feature remove the message, but then you don't have the feature.

Mikael Sandberg Community Champion Dec 16, 2016

As mentioned below, if you look in the sourcetree.log file you can find out which dictionary file is causing the message. In my case I had a dictionary file in my roaming profile that was causing it. You may have to check the log file multiple times until the message is not displayed anymore.

Yup, I had to do it twice (restart it twice and perform the same action), all fixed now. 

This worked for me also: disabled the option, restarted (got the warning), re-enabled, restarted, no more warnings.

I can verify that disabling restarting a couple times then re-enabling the option fixed it for me as well.

In my case SourceTree had a "stuck" dictionary file. I had to delete it manually.

This is on Windows 10.

You'll need to first find the location of the file.

Open SourceTree's log file in <user directory>\AppData\Local\Atlassian\SourceTree\sourcetree.log

Look for where it says something like this. Most recent entries are at the bottom.

ERROR [2016-12-16 11:24:35,973] [1] [SourceTree.Configuration.WpfSpellCheckerPreFlightCheck] [Run] - Keeping dictionary reference [C:\Users\&lt;user&gt;\AppData\Local\Temp\u3vdz0px.dic]
ERROR [2016-12-16 11:24:36,524] [1] [SourceTree.Configuration.WpfSpellCheckerPreFlightCheck] [Run] - Removing non-existent dictionary reference []

Note the location of the .dic and delete it.

 

I tried your method, it did not work, I'm still getting that message, it seems that sourcetree itself generating those invalid dictionary when it starts.

THIS one is the right answer.

In my case I deleted ALL the Temp folder content.
Next start of SourceTree showed the error but this time the list of disctionaires were there.
I clicked "Yes" (to remove the dictionaries), closed and restarted.
Error is no more there.

I also deleted the SourceTree_Url_ghasdhkfdsahkfg folder near the "SourceTree" one.
It contains a folder for every version you have installed (also the current one).
Bad idea. On the successive start of the program it begun the install procedure. I stopped it and restored the deleted folder (from the trash bin). Just 2 files about "configuration" (sorry, I haven't noted the names) was changed. I restored all with the old one.
Start again: OK.
I added this details to share the real experience I had but I think the solution was just to remove the bad disctionaries from the "Temp" folder.
version 1.9.10

Many thanks Isaac.

Yup @Alessandro Piccione that worked for me too.

I no longer get a dialog, but the log still shows this un-error: ERROR [2016-12-22 10:59:52,113] [1] [SourceTree.Configuration.WpfSpellCheckerPreFlightCheck] [Run] - Keeping dictionary reference [C:\Users\Sonny\AppData\Roaming\Microsoft\Office\16.0\5602c0c7\Proofing\RoamingCustom.dic]

I just deleted all the `*.dic` files in my temp folder. I figured, well they are "temp" files after all. That resolved it for me.

@Alessandro Piccione: The folder you deleted is your profile photo. The subfolders for each version are the settings for that version, in case you downgrade for some reason. You can clean those up any time you want, but you should leave the main folder there.

Besides deleting files in the temp folder, I also needed to disable "Spell check commit messages" in Options.

I got the same result as @Edward Savage - no more dialog but still error in log.

In my log file, I see a message about "Removing non-existent dictionary reference []". It seems to be an empty string or something. I can't find anything to delete.

 

ERROR [2017-01-01 04:43:26,708] [1] [SourceTree.Configuration.WpfSpellCheckerPreFlightCheck] [Run] - Removing non-existent dictionary reference []

I also have this issue and this solution hasn't worked for me. Currently running version 1.9.10.0. If I disable spell checking then there's no error but that's not a suitable solution for me.

I've tried repairing the installation and uninstall/reinstall but the issue still persists.

@Jason Mitchell

Have you found and deleted the missing dictionary from the Temp folder?

If this did not worked and you don't care to "rollback" to a previous version you can try to delete the
old settings of previous version of SourceTree. 
In <user directory>\AppData\Local\Atlassian\SourceTree.exe_Url_yjhzxxhcu2ommegrdorjf3q1oqllqxiq 
you can delete the directories of the old versions of SourceTree and leave only the current one (1.9.10.0).
On a different Windows 10 I had the same issues (solved on the other PC) and this was the simplest solution (I was too lazy to check the log and the precise dictionary files and I prefer to clean this old stuff).

I had to delete all the .dic files in following locations to get my machine to stop complaining:
C:\Users\<username>\AppData\Local\Temp\
C:\Users\<username>\AppData\Roaming\Microsoft\Office\16.0\7cc94ecf\Proofing\
C:\Users\<username>\AppData\Roaming\Microsoft\Office\15.0\9bf6f1b0\Proofing\

Thanks for the tip and all the comments.

The problem came back for me... sad

Michael check out Matt Slay (My post was similar as well).  It seems to work.

 

^ Thanks Tom, that worked for me.

Did work for me.

I had to Delete all *.dic files in the "temp" directory. 

Then, started Sourcetree and got the same notification but, this time it found the wrong entries and deleted them.

Since then, didn't received any notification.

This worked for me. Thanks!

This worked for me as well. Thanks!

Worked for me. I got the message again once I delete the files, but when I choose to remove the dictionary, and restart app, it worked fine. Thanks!!

Solved the empty list complaint!!

 

 In the registry value:

Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Spelling\Dictionaries in the property named "_Global_", there is a list of dictionary names. Right-click-> Modify on the value and the list of entries pops up in an edit window. Scroll down to the bottom, of the list there was a blank row with a carriage return, and I removed that row and it then stopped giving me the error where it complained when I launched it.

It was weird that after removing the blank line and I clicked OK, it popped up a message that said "Data of type REG_MULTI_SZ cannot contain empty strings. Registry Editor will remove all empty strings." I clicked OK on that message and everything is now fixed.

 

2017-01-21_5-23-01.png


Modify to get this widow, then remove blank line at bottom of list:

2017-01-21_5-30-04.png

When I clicked OK, it gave this warning:


2017-01-21_5-17-33.png


But now the problem is FIXED!!


This worked for me. I did not get the regedit warning either.

This worked for a day and then the error started occurring again. sad

This worked for me also, but it's just another band-aid solution. My last fix lasted for 2 weeks before I had the same issue again.

These exact steps solved it for me also.  At least afterwards, this was the first time I've been able to open SourceTree without getting the initial dictionary error.

This fix lasted less than a day for me. (I re-opened source tree maybe 3 times over the course of the day.)

The problem I am having is the blank lines keep on getting added back in by something.   Atlassian needs to change the routine to not generate an error for blank lines.

Helped for few restarts only. Got the problem again

When I updated to 1.10.20.1 the issue seems to have gone away.  I did do an uninstall before I installed as I wanted to reset my GIT as well.  I do have GIT Extensions installed as well and also uninstalled and reinstalled.

 

The problem came back for me.

 

I had to delete dictionary file ( "dictionary.lex" ) which was is located at C:\Users\<username>\AppData\Local\Atlassian\SourceTree folder and restart SourceTree. Its working fine now.

Once the application started it recreated "dictionary.lex". The error is gone and spell check is working as it should.

I'm in windows 10.  

 

I tried deleting this file as you stated, but it did not fix the problem for me

I looked in the registry key Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Spelling\Dictionaries in the _Global value it lists some files and I removed the one path where the file did not exist.  It worked today for me.  I hope it continues after the weekend

After deleting all *.dic files from the temp folder, I still get the folllowing error as @Edward Savage:

ERROR [2016-12-29 18:39:48,560] [1] [SourceTree.Configuration.WpfSpellCheckerPreFlightCheck] [Run] - Keeping dictionary reference [C:\Users\bibi\AppData\Roaming\Microsoft\Office\15.0\bbae5a57\Proofing\RoamingCustom.dic]

The beginning of the file(RoamingCustom.dic) looks like this:

'
'Anita
'Daniel
'David
'Denis

I deleted the first line (the one with the single "single quote") and the error went away smile

I searched for .dic in the

C:\Users\spryce\AppData\Local\Temp\ 

folder, then deleted all. After restarting SourceTree I received the same invalid dictionary message however this time there was actually a list of invalid .dic files in the message. I confirmed yes to removing them and then restarted again.

Error message gone.

 

This lasted about 2 weeks for me. Since that time I've tried a few other methods, the last attempt lasted less than one day, but it seems these are all temporary clean ups and dont resolve the crux of the problem.

I solved this by turning off the commit spell checking option, restarting Source Tree, pressing "Yes" to removing the invalid dictionaries, then restarting Source Tree again. Problem was gone.

Scott

It's nice that people were able to work around this by turning off the feature, but that is not a fix.  If Atlassian can't reliably fix the problem when you click yes, they should either fix it or remove the attempted fix.

I had to delete the folders under "C:\Users\<username>\AppData\Roaming\Microsoft\Office\16.0", once I did that it resolved the issue. Just removing the .dic file didn't seem to be enough. 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

647 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you