SourceTree losing saved passwords

SourceTree keeps prompting me for my password for my Bitbucket account. I click the save password box and sign in. When I go into the Tools>Options>Authentication menu I can see my account has been added to the set of saved passwords, but after some period of time, sometimes 10 minutes and other times 30 seconds, I get another box prompting me for the same password again. Often this occurs when SourceTree is idling in the background and not actively doing anything. Looking at the authentication menu again I can see that the password and username have been removed from the saved passwords box. I'm using SourceTree 1.8.3 but this has been happening for a few iterations.

7 answers

Temporary solution: disabled the option to check for remote updates.

Tools >> Options >> General >> 

image2016-10-19 14:54:27.png

Disadvantage: I have to update manually. (pull or fetch).

Remark: The same question: https://answers.atlassian.com/questions/276680

This was a lifesaver. Thank you.

Holy cow this is the most annoying *#$%&#$%&!ing thing EVER!!  It's been doing it for 6+ months, several times a day it just decideds to forget the password even though under Options->Authentication->Saved Passwords I can clearly see it in there after entering it.  Everyone in my lab is having the same issue. We try to close SourceTree when we're not using it, but if you ever forget and leave it up for a few hours, grrrrrrrrrrrrrrrrr ANGER! lol!  WTF? Fix it already!!

I'm having a strange issue with SourceTree on my laptop, working fine on my main machine, both running Win7. The SourceTree password manager seems to be getting into an argument with 'Git Credential Manager For Windows'.

The credential manager remembers nothing and the SourceTree manager remembers only the user name. They both pop every 10 minutes for auto check and whenever I need to pull or push.

 

That sounds very similar to my issue but I dont have Git Credential Manager For Windows so maybe there is something else that is conflicting with both. I'm not sure what though.

I have the exact same issue - massively frustrating. The credentials disappear from the list and I am prompted to enter them again.

 

I have tried uinstalling Windows Git Cred. manager but they had no effect.

I have the same problem for one account, while another account is stored correctly.
Strangely this account is working fine on another computer with SourceTree.
Both computers have the same SourceTree version: 1.9.6.1

No reply from Atlassian? Not really what I would call "dedicating our support staff to focus on offering the same support you know and love via Atlassian Community instead." (https://blog.sourcetreeapp.com/2017/05/09/sourcetree-support-moving-to-atlassian-community/)

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

274 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot