Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree is repeatedly asking for Bitbucket credentials Edited

I am using SourceTree v2.6.9.0 on Windows 10. My repositories are in Bitbucket, and my Bitbucket account has 2-step verification.
For several days, maybe about a month, SourceTree has started showing a dialog asking me for my Bitbucket login, about every 20 minutes or so.

BitbucketLoginInSourceTree.PNG

This is the dialog that I get. The difference is that it has the username pre-filled.


It doesn't matter if I enter my credentials, or simply close the dialog without doing anything, the dialog keeps popping up several times a day. And also, I can keep pushing and pulling without issues, even if I just simply ignored the dialog and closed it.
Other people in my office, with the same version of SourceTree, and accessing the same repositories in the same way, don't get these. The one difference between them and me is that I have been using SourceTree for about a year, or more, while everyone else started using it, on my recommendation, in the last couple of days. This has made me think that a fresh install would solve my issue, but I am not convinced. There should be a better solution.

I've tried solutions like this one https://community.atlassian.com/t5/Sourcetree-questions/SourceTree-continuously-prompting-for-colleague-s-BitBucket/qaq-p/601906
without complete success. After following the instructions on that answer, I don't get the login dialog every 20 minutes, but now every 2 hours and 40 minutes (yes, I write the time every time I get the popup).

I am not sure what else to do, apart from uninstalling, and re-installing SourceTree.

2 answers

0 votes
Mike Corsaro Atlassian Team Jul 06, 2018

Hello! Could you try removing all the accounts in the accounts page, restart Sourcetree, and then try and re-add them? It sounds like an old access token is being held somewhere.

Hi Mike. Thank you for your reply. I have tried what you suggested. I have gone to Tools > Options, and on the Authentication tab I have deleted all accounts as well as all saved passwords. That page was left empty. I then restarted SourceTree, went back to that page and added my Bitbucket account, selecting SSH protocol and OAuth authentication. But again, I am getting prompted for credentials every 2 hours and 40 minutes.

Then I tried again, deleting all accounts, restarting SourceTree, but this time not adding a Bitbucket account. Still same effect. After a while it started asking for my Bitbucket account credentials.

I am having the same issue.  Please help!!!

At the end I decided to uninstall Sourcetree completely, and re-install it.

Now I don't get the popups.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,251 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you