Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


SourceTree Push Dialog Empty

Using version 3.2.6 in Windows, starting this morning my push dialog is empty. I can fetch, commit, or merge just fine. And after merging or committing the button shows how many things need to be pushed. But the push dialog is empty, as in it doesn't show any branches. Before today it always showed all the branches, with the one I had checked out selected by default. Now there are no branches in the list at all. This is true no matter which local repository I am working in.

I should also note that if I use the command line, the push works just fine.

Any hints about how to fix this are greatly appreciated.

1 answer

1 accepted

5 votes
Answer accepted
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Sep 10, 2019

Hi Clayton,

Thanks for reaching out! A similar issue was reported on this other post. The issue seems to be caused by an older version of Git. The solution is to upgrade Git to 2.23.0. Please update your Git and let us know if it works for you now.

Best regards,


Ana -

Thanks for the link to the other post. Unfortunately I have no control over the version of Git used at this client, so I had to roll back to v3.1.3, which also solved the problem.

I am curious as to why I can update to 3.2.6 through the application, but 3.1.3 is the latest version available on the download page.

Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Sep 11, 2019

Hi Clayton,

Why is that you have no control over the Git version? You can update your own (system Git) or the embedded Git (included with Sourcetree) as per the article Using embedded git or system git in Sourcetree.

Regarding your second question, Sourcetree versions are not rolled out for all the users at the same time, so we don't update the version on the website until all our users have been offered the new one. I'll check with the team and see if we're ready to update the link on the website. If you'd like to update your Sourcetree again, you can do so form the menu Preferences > Check for updates.

Hope that helps!


Just wanted to chime in that I ran into a similar issue with the latest update, and updating the Embedded Git fixed it for me. So the issue still pokes up it's ugly head at times, but Ana's suggestion does fix the issue.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events