It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree/OSX/Mercurial - Error trying to clone, pull, push after changing credentials

David Malaguti Oct 09, 2017

Using SourceTree 2.6.3 (134) on OS X Sierra.  I tried to change the credentials for my Mercurial repository, and now any attempt to pull, push, or clone a new repo results in an error, listed below.  I've tried removing and reinstalling SourceTree entirely and I still get the same result.  

 

>>>>>

hg pull -u default 

pulling from https://my url

Error calling askpass for username: 2017-10-09 10:43:59.269 SourceTreeLogin[9666:377251] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSPlaceholderMutableString initWithString:]: nil argument'

*** First throw call stack:

(

0   CoreFoundation                      0x00007fff9706857b __exceptionPreprocess + 171

1   libobjc.A.dylib                     0x00007fffac2c71da objc_exception_throw + 48

2   CoreFoundation                      0x00007fff970e5c55 +[NSException raise:format:] + 197

3   Foundation                          0x00007fff989f8ad1 -[NSPlaceholderMutableString initWithString:] + 96

4   Foundation                          0x00007fff98a363c4 +[NSString stringWithString:] + 45

5   SourceTreeLogin                     0x000000010015c0c6 SourceTreeLogin + 12486

6   SourceTreeLogin                     0x000000010015beec SourceTreeLogin + 12012

7   SourceTreeLogin                     0x0000000100178972 SourceTreeLogin + 129394

8   SourceTreeLogin                     0x000000010017ec83 SourceTreeLogin + 154755

9   SourceTreeLogin                     0x000000010015a9e0 SourceTreeLogin + 6624

10  libdyld.dylib                       0x00007fffacba8235 start + 1

)

libc++abi.dylib: terminating with uncaught exception of type NSException

abort: http authorization required for https://my url

Completed with errors, see above

1 answer

0 votes
Brian Ganninger Atlassian Team Oct 09, 2017

Please file a ticket at https://jira.atlassian.com/browse/SRCTREE with those details and we'll take it from there. Thanks for the report!

Brian Ganninger
Senior Mac Developer, Sourcetree

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

1,946 views 14 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you