It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree: Is there any way to turn off file preview / diff on a file or file type?

Aaron Cammarata Aug 14, 2014

I've got a large file that happens to be stored in text (Adobe Illustrator), and every time I make even a tiny change the entire file gets previewed with green/red lines in SourceTree. It brings ST to a crawl for 20 seconds, while it goes line by line through the file for changes. I really don't need to see the file previewed at all, so is there any way to tell ST that I'm not interested in previewing or diffing the file? I would be happy to give up previewing on all files of type .ai if necessary.

This is on Mac, if it matters.

4 answers

1 accepted

3 votes
Answer accepted
Aaron Cammarata Aug 23, 2014

Thanks to Steve Samuels, who answered it in this thread.

Use the Diff panel in preferences, edit filter by file type, add the file type (ex: "*.ai"), and then RESTART SOURCE TREE for it to take effect.

Gianfranco Palumbo Feb 18, 2017

This works. Would be great though if you could disable the diff preview ONLY when selecting multiple files.

Comparing a single png works fine on my Macbook Pro with SSD, but when you select 5 or more it just grinds to a halt.

5 votes
Torsten D Nov 18, 2014

Hi there,

I am using the Windows version 1.6.11.0. Is this still in there. Cannot find it.

I can find a filter to show only certain files in the unstaged/staged section.

But I would like to disable the preview of the diff on certain files (I am having compiled files which take about 5 seconds to show on the right (preview) panel). These I would like to hide.

fireice007 Jul 01, 2015

Max File Count 0 to disable

3 votes
Paul van den Dool Aug 01, 2018

A bit of an old thread, but it was the top search result when I Googled, so I thought I just leave my solution here.

I too had an issue where SourceTree crawled to a snail pace when there was a big file in my changes. It's a file I want to commit, but don't need to review. Ignoring it would be the solution.

I couldn't find the "filter by file type" mentioned in the answer. But entering the exact name of the file in "Ignore File Patterns" worked (after restart). See screenshot.

Screen Shot 2018-08-01 at 3.33.45 PM.png

Andrei Bouariu Sep 27, 2018 • edited

You just won the achievement for the best comment on the Internet. I didn't need to add package-lock.json to the ignore file pattern, mine was about 600 KB and set the Size limit (text) to 100 KB.

Boom, package-lock.json no longer previewed.

George Song Oct 31, 2018

There seems to have been a regression on this feature in v3.0 (200). `pacakge-lock.json` is no longer ignored for diff preview.

0 votes
Latheesan Sivarasathurai I'm New Here Mar 08, 2019

I solved different issue using this fix. My SourceTree running on Windows would become unresponsive when it comes across a minified file. I turned off the Max File Count, then changed it to 1. Now it is working like new. :)

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

448 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you