SourceTree 1.4 for Windows kills performance

I updated this morning to SourceTree 1.4 for Windows. When I let the installer re-launch SourceTree, it basically just hung. No matter which of my repos I chose, I just got an endless (I gave it about 5 minutes) spinning icon. It never did show me the status of my repository.

Then, I noticed that Windows in general was very sluggish, so I popped open task manager to find that my cpu (8 core i7) was being 100% utilized by several (8, maybe?) instances of git.exe that had been launched by SourceTree.

I quickly uninstalled SourceTree, and reinstalled version 1.3.3. I will stick with that, until this issue gets sorted out.

2 answers

2 votes

Have you logged this as an issue with Sourcetree at https://jira.atlassian.com?

Whilst Atlassian do read stuff here, they might not pick this up as an issue. If you log it, they'll look into it.

Perfect. Thanks; I'm new to the Atlassian world.

We're not seeing any performance characteristics like that here (~50 bookmarked repos), can you reproduce this behaviour? If so please raise with more detail at https://jira.atlassian.com

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

831 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you