It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Source tree cannot connect to github.

My sourctree previously working fine.

Then now suddenly i cannot pull, push or clone from github. Everytime i try to refresh the remote repositories keep getting error. It says authentication required, i keep facing github login, input the correct input, still fail to refresh. I already try update to the latest source tree and download latest github scm. Even try to remove and add account still not working, also try delete all my github related key chain, still not working. I got like 3 project running and pending for push, what should i do ?. If somebody has found the answer, please help !, remote if you can, i've been looking for the whole day just to deal with this. Thank you.

1 answer

0 votes
Ana Retamal Atlassian Team Mar 28, 2018

Hi Ibrahim, the solution for that was shared in this thread: https://community.atlassian.com/t5/Sourcetree-questions/How-do-I-setup-Sourcetree-to-access-Github-now-that-they/qaq-p/735377

Basically, you just need to update your version of Git so that the credential manager supports Github's recent security changes and you should be good.

As an alternative, you can try pushing using your command line.

Best regards!

Ana

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,902 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you