Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,035
Community Members
 
Community Events
165
Community Groups

How do I setup Sourcetree to access Github now that they deprecate weak cryptographic standards?

Github turned off some cryptographic standards for access today.  Reading the notice:

 https://githubengineering.com/crypto-removal-notice/

it appears that TLS 1.2 should work, but when I choose "Enable TLS 1.2" on the Network tab of the Options dialog, I continue to receive the following error.

 error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

How do I setup Sourcetree to access Github now that they deprecate  weak cryptographic standards?

I am using Sourcetree Version 2.4.8.0 on Windows 7 and also 2.4.7.0 on Windows 10.

 

Thank you.

2 answers

1 accepted

7 votes
Answer accepted

The problem is that SourceTree's embedded git client comes with git-crediential-manager v1.12, which no longer works now that Github has disabled TLS 1.1.  Until they update the embedded git package, you'll have to switch to a system git client with git-credential-manager v1.14, or manually replace git-credential-manager in your embedded git client with v1.14.  You can get the new version of git-credential-manager from Microsoft's Github page.  I just downloaded the ZIP and extracted it to C:\Users\USERNAME\AppData\Local\SourceTree-Settings\beta\git_local\mingw32\libexec\git-core, but your path my vary.

Works perfectly. Thanks!

Thanks, Andrew, for the quick response and useful information beyond just a suggestion!

Your suggestion also worked for me after I updated the embedded Git version from 1.95 to 2.15.  I deviated a bit from your procedure in that I ran the .exe version of the installer rather than unzipping.

While access to Github works, I get some disconcerting messages during the process which I don't think I used to see. Do you see these?

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin
fatal: HttpRequestException encountered.
An error occurred while sending the request.

From https://github.com/<myaccount>/<myrepo>
08396f5..9825d82 master -> origin/master


git -c diff.mnemonicprefix=false -c core.quotepath=false pull origin master
fatal: HttpRequestException encountered.
An error occurred while sending the request.

From https://github.com/<myaccount>/<myrepo>
* branch master -> FETCH_HEAD

Updating 08396f5..9825d82
Fast-forward

src/TestApps/IdiomaEleccion/Program.cs | 2 ++
1 file changed, 2 insertions(+)

Completed successfully.

I also had this problem, but there's no need to put the Windows Github Manager at the path. Instead, SourceTree has a setting where you can choose to use the "System Git" instead of the "Embedded Git". Make sure Git is updated locally, then in SourceTree go to "Tools > Options" then the "Git" tab, then click on "Use System Git" at the bottom. See here:

Like Yamini likes this

That does not work, it is disabled just like in your screenshot

mine looks a tad different but I clicked System, and it did disable like you're showing, but when i did "origin - Fetch" - at least it does not error, it says Completed Successfully; but, back in my main tab, origin shows nothing. just blank, no files. ideas??

@Matt Cromwell This resolved my issue many thanks!

Like Matt Cromwell likes this

@Dino B mine was disabled because it was the one in use. If "Use Embedded Git" is bold, then it means it's available to be clicked/chosen. It's honestly not the most intuitive UI here at all, but if it's greyed out then it is most likely Enabled. 

Hi,

 

Thanks for the information your answer make my day. Actually i was looking for the grade topics solution and your post is related to my requirnments. Thanks alot for sharing your valuable information but i think i have some thing which can boost your knowledge for it read more...., 

 

Regards,

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,832 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you