It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Source Tree installation fails with Error code -36 on a mac

I'm trying to install source tree on a macbook pro running 10.6.3. When trying to install source tree I get the following error message "The Finder can't complete the operation because some data in "SourceTree.app" can't be read or written. (Error code -36)." I should mention that I tried to download an older version of Source Tree a few months ago and got the same error and gave up on it. I've also tried using the same installation file that a coworker used (successfully) and that didn't work either. Any tips?

3 answers

1 accepted

0 votes
Answer accepted

Hi Jonathan,

Error code 36 is an I/O problem (this is an OS-level concept) which usually means there's something wrong with your hard disk. Have you got some external disks you're using for repositories or trying to load SourceTree from an external drive?

There's a thread regarding this error code here: https://discussions.apple.com/thread/2145463?start=0&tstart=0. It's all related to communication with some external disk usually, but otherwise it could be there's something wrong with your hard disk rather than an external one.

If you search for that error you'll get many related results, a lot of them suggesting you need to re-format your hard disk unfortunately.

Cheers

Thanks for the response Kieran. You are correct, it turns out I did have a couple errors on my hard disk. I repaired the disk and the os is now telling me the disk is ok. I tried downloading the install file again and even after repairing the disk I am getting the same error (-36).

It may suggest your disk is having more problems regardless of a disk repair. If you look through various threads others had also stated they continued to get errors after a disk repair. Are you doing anything over a network, i.e. external drives?

After looking into it further it does seem like I was having more disk problems. After swapping out the HD in my machine I was able to successfully install source tree.

Glad you got it working, Jonathan :)

Reboot your Mac to Recovery Mode.
Open Disk Utility, select your drive, and erase it using the options in the Erase tab.
Quit Disk Utility.
Use the backup recovery utility to restore your recent backup.
for more info visit this URL
https://www.errorsolutions.tech/error/mac-error-code-36/

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,962 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you