Not a Valid Source Path / URL OSX

Hi there,

I've found a few threads complaining about a similar issue, however their resolutions don't seem available to me. Basically I can see my list of Bitbucket repos, but when I click 'Clone' the URL is empty, if I paste in the repo URL the "This is not a valid south path / URL" error doesn't go away.

But by all accounts it doesn't seem you can disable Git? Is it possible that some install process hasn't run? 

I'm on OSX.

Thanks in advance!

3 answers

1 accepted

7 votes
Accepted answer

Experiencing same problem on clean macOS installation. So downgraded to 2.3.2.

Hi Dmitriy,

I can't seem to find a list of older OSX versions of SourceTree, where did you get the older version?

Hey Kevin,

That version worked perfectly. Perhaps it's an issue with the latest?

Same problem, solution worked, thx

thank you, it's working

Had to downgrade as well to 2.3.2. Latest 2.4 didn't work.

This seems to have been fixed in the latest release (2.4c): https://downloads.atlassian.com/software/sourcetree/SourceTree_2.4c.zip

Still a problem with 2.7.1 Mac

Switched to Basic auth with HTTPS and restarted. Now finding repo.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

828 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you