Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,439
Community Members
 
Community Events
168
Community Groups

No longer able to create repos on Github using SourceTree

Hello, I am unable to create repositories on Github using SourceTree. Unsure when the issues started, I just noticed it yesterday. I am still able to do commits to existing repos and clone existing repos, I just can't create new repos.
Running OS X Mojave, 10.14.1
Running SourceTree 3.0.1 (205)

I already reached out to Github, below is what they had to say:

"Thanks for reaching out. I don't see any problems on our end with your account. The error you were shown is something returned by our API, but we didn't develop SourceTree so it's hard for us to say what kind of API request the application is making in order to explain why the API is responding in such a way. Can you reach out to SourceTree support and ask for logs which show the exact API request that is being made (including all headers)? That should help us help you debug. On our end, there are no problem with the API and other users are able to create repositories via the API, so this seems like a problem on your end with SourceTree and we need more information to help you debug."

Thank you for any help.
Doug

1 answer

0 votes
bgannin Atlassian Team Dec 12, 2018

Hi Doug,

Our apologies for the hiccup. You can see what requests are being made by following this article and using the Network Monitor. After that we'll be in a better place to diagnose the problem. A ticket in our public bug tracker is the best way for us to track an issue. Thanks!

Brian Ganninger
Senior Mac Developer, Sourcetree

bgannin Atlassian Team Dec 12, 2018

Please include the error information for us to review as well.

Thank you for the reply. I will perform the above tasks and post the results here within the next day or two.

Thanks again.

I tried to create a ticket using the link above, but I didn't know what info to provide for most of the fields, and it wouldn't let me leave the fields empty, even when using the custom setting. So the info I have is below.


MacOS Mojave 10.14.2
SourceTree Version 3.0.1 (205)

---------------------------------------

New -> Create Remote Repository

Under Network Monitor
Context: GHFetchTeams
Body: empty

---------------------------------------

Create Remote Repository -> Create (button)

Under Network Monitor
Conetxt: GHCreateRemoteReop
Body: {"name":"test-repo","private":false,"description":"This is a test repo."}

---------------------------------------

The pop-up error that I get.

pop-up-error.png

I am still experiencing the same issue of not being able to create a remote repo on Github. I also tried removing and reinstalling Sourcetree. Any recommendations?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events