Tip from the team: debugging Sourcetree

Supported Platforms

  • macOS
  • Windows

If you're reading this and it's not just educational… we know you're unhappy right now and apologize for that (sad) We're dedicated to improving your Sourcetree experience.

We need your valuable feedback though to help narrow down the problem and ship a fix that much faster. Here are some high level details on what we've already built into Sourcetree to aid in flipping the switch from:

broken_switch.gif

macOS

Visit the Advanced preferences pane and turn on the Debug menu to make it easier to access options and logs. As noted, some changes (such as the log level) require you to restart the app for them to take effect.

Screen Shot 2018-05-10 at 2.57.29 PM.png

Once the Debug menu is enabled, you can:

  • Change several logging settings
  • Open up debug monitors and inspectors to see what's going on
  • Use the Tasks Monitor to help determine what actions are being run in response to a particular click
  • Use the Network Monitor to help determine what activity is generating traffic unexpectedly, such as populating the remote repositories list in the background

Screen Shot 2018-05-10 at 2.54.23 PM.png

Windows

It's even easier to get started finding behind the scenes activity on Windows via the Process Log under the Tools menu. When you open it, you'll see data presented like so:

image2017-12-19_16-25-34.png

 To enable logging in general for the app you'll need to edit %localappdata%\SourceTree\app-{version}\log4net.config and set the value to DEBUG. (more details) Once you've done that you'll find the output in %localappdata%\Atlassian\SourceTree\sourcetree.log

Despite the playful gifs and useful functionality we built in, it's never fun to run into a problem with tools you depend on day in and day out. We appreciate you taking the time to learn what's available to help file the most informative and actionable tickets possible.

1ky4w12.gif

Thank you for your help in eliminating those pesky bugs!

Note: debug data is generated only a when monitor is open and none of it is ever transmitted off your machine

Additional Reading:

10 comments

Guys, I appreciate you want to fix the bugs but a lot of them are so fundamental. Like the commit button sometimes works, sometimes doesn't. Have to click it twice, three times. You have a rock solid Git layer underneath a GUI. All that is needed is to get the presentation right. Rather than getting your users to do testing, maybe look at what more your test department and QA can do. 

Bob Helm I'm New Here May 23, 2018

I had to uninstall it. I upgraded to the latest some weeks back and it wouldn't launch. I uninstalled and reinstalled several times, and it still wouldn't launch. It kept asking me to upgrade .NET Framework. I did that, still no dice. Is that fixed with the latest?

Thanks for this, and I've tried it. SourceTree still goes to 100% on the Mac, and when I open the log there's a bunch of 429 responses for Pipelines. We've seen an association with Pipelines for this issue. Maybe the 429s are making SourceTree spin internally? Perhaps queuing to try again? 

Know what's a great way to find deep-rooted bugs? Porting to another platform! Challenge your assumptions about how the OS and GUI toolkit should behave and you might discover the cause of all these crashes...

Debug -> Open Logs Folder doesn't even work. Come on guys.

On Mac, I get the rainbow cursor constantly. It's the only app I use that I know it doesn't (necessarily) mean it's crashed, you just have to go do something else for awhile and then it'll work again. Rinse and repeat for every action.

On Windows (10), a simple click on a file and the app thinks you're holding down and dragging. I have to slowly double click (so as not to open) a file to begin every selection process.

It really seems to me like Atlassian could care less about Sourcetree. It could be an app that gives Bitbucket a great advantage over competitors but, if anything, it's an example of why people shouldn't trust them.

@Stuart Watt There is a fix for cache misses with Pipelines in 2.7.4. Please file a ticket if you experience problems still.

We finally found the fix our massive performance problems with source tree. (taking 20mins to commit even a single file).  It turned out to be a conflict with the Antivirus that was blocking everything. 

A guide for configuring Antivirus programs to avoid performance issues would be nice.

I stopped use SourceTree recently due to serious performance issues. Basically getting the rainbow beachball for even really simple operations. I still like the idea of having a GUI for visualizing branches and such, but I've found it was more of a crutch than a necessary tool. 

Comment

Log in or Sign up to comment
Community showcase
Published 9 hours ago in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

56 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you