It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Missing parameters

I got the following information while running SourceTree:

2017-08-25 08:03:04 +0000 (e) Parameters required to generate access token are missing. Please report to Atlassian via Get Support in the Help menu.

2017-08-25 08:03:04 +0000 (e) mAuth instance not initialized properly

2017-08-25 08:03:04 +0000 (e) [AUTH] Error: Cannot Authorize (Bitbucket)

2017-08-25 08:03:05 +0000 (e) Parameters required to generate access token are missing. Please report to Atlassian via Get Support in the Help menu.

2017-08-25 08:03:05 +0000 (e) mAuth instance not initialized properly

2017-08-25 08:03:05 +0000 (e) [AUTH] Error: Cannot Authorize (Bitbucket)

2017-08-25 08:03:05 +0000 (e) Parameters required to generate access token are missing. Please report to Atlassian via Get Support in the Help menu.

2017-08-25 08:03:05 +0000 (e) mAuth instance not initialized properly

2017-08-25 08:03:05 +0000 (e) [AUTH] Error: Cannot Authorize (Bitbucket)

2017-08-25 08:03:05 +0000 (e) Parameters required to generate access token are missing. Please report to Atlassian via Get Support in the Help menu.

2017-08-25 08:03:05 +0000 (e) mAuth instance not initialized properly

2017-08-25 08:03:05 +0000 (e) [AUTH] Error: Cannot Authorize (Bitbucket)

2017-08-25 08:03:05 +0000 (e) Parameters required to generate access token are missing. Please report to Atlassian via Get Support in the Help menu.

2017-08-25 08:03:05 +0000 (e) mAuth instance not initialized properly

2017-08-25 08:03:05 +0000 (e) [AUTH] Error: Cannot Authorize (Bitbucket)

 

What should i do now?

1 answer

0 votes
Ana Retamal Atlassian Team Aug 25, 2017

Hi Dominique, can you provide some more information so we can help you fix this issue?

  1. Which OS are you using?
  2. What SourceTree version do you have?
  3. When did that error happen? What operation where you performing?

If you were just trying to install it, can you try a re-install? The steps for a clean re-install are as follows:

  • If you're in Windows:
    1. Wipe SourceTree preferences
    2. Uninstall SourceTree (if it shows on the App&Features list)
    3. Backup then delete the directory below before proceeding with next step
      • Navigate to C:\Users\<UserName>\AppData\Local and delete SourceTree & SourceTree-Settings folder
      • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all SourceTree Files/Folder.
    4. Download SourceTree and install it. 
  • If you're in Mac:
    1. Wipe SourceTree preferences
    2. Uninstall SourceTree (if it shows on the App&Features list)
    3. Delete the directory ~/Library/Application Support/SourceTree
    4. Download SourceTree and install it.

Let us know!

Regards,

Ana

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,935 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you