Invalid redirect_uri error while connecting to Bitbucket

Sewon Jeong June 4, 2019

I'm getting "Invalid redirect_uri" error during the registration using my Bitbucket account.
sourcetree.png

It seems like it goes through if I manually replace the characters in redirect_uri but the installation window goes back to the Registration step and can't go to the next step.

sourcetree2.png

 

sourcetree3.png

6 answers

1 accepted

0 votes
Answer accepted
Sewon Jeong June 5, 2019
0 votes
Mikael Sandberg
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
June 5, 2019

This is a known issue and Atlassian is working on it, see this thread for more info, https://community.atlassian.com/t5/Sourcetree-questions/Cannot-login-to-bitbucket-in-order-to-use-sourctree/qaq-p/1100226.

0 votes
Jimmy Seddon
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
June 5, 2019

Hello Everyone!

It looks like you all might be running into this: 

https://jira.atlassian.com/browse/SRCTREEWIN-10965

While there isn't a posted solution for it yet, you might want to go vote, watch and comment on that issue.

Sorry I can't offer more help.

-James

0 votes
Adrian Krysiak June 5, 2019

Same problem here. I have tried to install different versions 3.x but problem still exists

0 votes
KarateCarrot June 5, 2019

Same problem. Does anyone have a solution?

0 votes
Alex Ge June 4, 2019

Same Problem here, waiting for solution!

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events