It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot login to bitbucket in order to use sourctree Edited

After installation of sourcetree (on windows7) it asks me to login to my bitbucket account.

login.jpg

But all I get is this message in the browsers window:

invalid_redirect_uri.jpg

I can't use sourcetree, because of failed Registration. Please help!

kind regards

1 answer

1 accepted

1 vote
Answer accepted
Andy Heinzer Atlassian Team Jun 05, 2019

Hi Holger,

Sorry to hear about this problem with logging into a Bitbucket account from Sourcetree. However this is not just you that is having this problem. There is currently an outage in regards to Bitbucket Cloud via OAuth are not working correctly. This is the cause of the inability to login here and in turn showing that 'Invalid redirect_uri' error message.

Atlassian has just updated our StatusPage about this incident that you can use to track this problem in https://bitbucket.status.atlassian.com/incidents/l50d1j43zdj9

I would recommend subscribing or watching that incident for update. Once this incident is resolved I would expect that you should then be able to use Sourcetree without this error.

In the meantime, you could work-around this issue by trying to use the SSH login method for Sourcetree, Seadna Smallwood created a step-by-step guide on how do this in https://community.atlassian.com/t5/Sourcetree-questions/Re-Cannot-setup-SourceTree-stuck-at-OAuth-authorization/qaq-p/1100478/comment-id/29692#M29692 has more details about this method.

Sorry again for the inconvenience here.

Cheers,

Andy

Hi Andrew,

thank you! It works!

Hi,

I face a similar issue here on a brand new mac pro running Mojave (which cannot be upgraded due to company policy).

I am stuck at step. of installation (using sourcetree 3.2.1) without the mentioned error box.

I have created a bitbucket account and confirmed my registered email address. But it seems the registering process never returns to sourcetrees installation wizard.

Switching the internal WLAN to the guest WLAN did not help.

Hope this gets fixed soon.

 

Regards,

Stephan

Answer to myself for the case that someone stumbles upon the same issue:

After clicking on the link at the bottom of the wizard and creating a bitbucket account and confirming the email address one has to click on the big "Bitbucked Cloud" button which will take you to web page where you have to click on the "grant access" button.

After that the further installation process is unlocked.

Ohh - this is not intuitive at all folks!

Kind regards,

Stephan

Like Denis likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,947 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you