I have a remote repository in bitbucket and a local, but I cannot get them connected. Do I need SSH?

I can log into the bitbucket, and I can see the remote in SourceTree. But I cannot commit. 

I have tried adding SSH but following the instructions don't change anything. 

Should I delete the remote and re-add with the key? 

1 answer

1 accepted

0 vote

Do you get an error message when trying to commit? Are you also pushing when committing? If you get an authentication failure error you should have a look at this thread, https://community.atlassian.com/t5/Bitbucket-questions/SourceTree-2-1-10-0-Authentication-Issues/qaq-p/623202

I have tried to upload the SSH public key to bitbucket that was generated in the Putty in SourceTree but I get an error that says its an invalid key. 

Mikael Sandberg Community Champion Aug 23, 2017

Did you copy the key string directly from PuTTY Key Generator or from the saved file? If you copied it from the file, have you tried loading the key in PuTTY and copy it from there?

Thank you!I was copying from the text file and when I did it from putty it worked.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

548 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you