Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,196
Community Members
 
Community Events
165
Community Groups

I get authentication failed messages when trying to pull/push

I use a personal access token from GitLab to authenticate over HTTP. I recently generated a new PAT and tried to replace the old one but now I am unable to push, pull, fetch or do anything else. Below it says authentication is OK.

 Capture.PNG

But then when I try to clone a repo I get access denied. This only happens on my home PC, my office PC made the switch without a problem. I have tried uninstalling and reinstalling many times.

Capture.PNG

1 answer

Go to this path : C:\Users\{username}\AppData\Local\Atlassian\SourceTree and delete the file named passwd

Now come to source tree and Try to pull, this time a popup will showup asking for your password,

Enter your newly created PAT token as password.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,888 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you