I am getting an error when trying to push Edited

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

Updated to the latest version. Was able to push 2 days ago just fine. Also I can OAuth just fine, but I can't push

1 answer

0 vote

 

Hi Jaycee, I found this thread created by another member of the Community where some users share the solutions that worked for them regarding this issue. There are 3 available solutions right now, I've listed them here for you, you can find the post at Authentication issues:

  • Delete the Windows Credentials stored in Windows (that's where SourceTree stored them), delete the passwd file, then restart SourceTree. To see and remove them, do the following:
    1. Open the Control Panel and click on User Accounts.
    2. In the left hand list of links, click Manage Your Credentials. When it opens, it shows your Web Credentials. 
    3. Click the Windows Credentials "button". This shows your stored Windows credentials. Look for entries that start with "git:http" and include your server name and/or user name and remove them.
  • Go to Repository > Repository Settings, selecting my repository, and changing the username from my old Bitbucket username to my Atlassian account's email address. Then, following your original advice to remove the passwd file, I was able to successfully pull.
  • Download SourceTree version 2.1.2.5 from our website and install it. Reject the upgrade to 2.1.10 that comes up.

I hope this helps you! If none of the above works for you, please let us know if you're using Windows or Mac, if you get the same error when you perform different operations, and if you get errors if you use the terminal instead.

 

Best regards,

Ana 

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

262 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot