Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,236
Community Members
 
Community Events
176
Community Groups

How to get past "Oops, you've made a malformed request" in Sourcetree

In attempting to install Sourcetree, I can't get past step 3 "Atlassian Account".   When I try to log in with Sourcetree I get "Oops, you've made a malformed request".  I tried various suggestions such as making IE my default brouser, clearing cache, etc.  Same result.  It appears other people are having the same problem with no resolution. 

3 answers

On Windows 10, I switched my default browser from Edge to Chrome and the login worked fine with Chrome, as it forced atlassian sourcetree installer to open the login page in chrome. This might be helpful to someone.

I just ran into this problem in Chrome- I opened a new tab and logged into Bitbucket, then retried in Sourcetree, and it worked.

Looks like Atlassian's login redirect is mangling the oauth url.

0 votes
Ana Retamal Atlassian Team Apr 03, 2018

Hi Chuck! Try going to Control Panel > Network and Internet > Internet Options,  then go to the Privacy tab and set the Internet zone setting slider all the way down to "Accept All Cookies". Re-install the app and let us know if you can register this time.

If this is still not working, let us know which OS and Sourcetree version are you using.

Kind regards!

Ana

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events