Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I log in to Sourcetree??

Hello,


I've been using Bitbucket, and want to work with it through sourcetree but I'm running into some issues.

After getting past some non-obvious setup steps (I have to manually install .NET libraries on my own then re-run the sourcetree installer) I try to log into bitbucket server and get an error saying "Invalid URI: The hostname could not be parsed." 

I instead tried to log in with an Atlassian account. That also didn't work as it refused to accept my password even after multiple password resets.

 

How can I use this tool????????

1 answer

0 votes
Mike Corsaro Atlassian Team Jul 25, 2018

Hello! Re: Bitbucket Server -- what's the URL that you're using for your hosted Bitbucket Server server?

 

For Atlassian Account, could you try following the steps listed in this post? Thanks!

the URL is http://local-server-name/
my username is first.last@company.com

It seems to break with the '@' in my username. https://jira.atlassian.com/browse/SRCTREEWIN-7933

How has this not been addressed in almost a year?

Like Barbora Darmova likes this
Mike Corsaro Atlassian Team Jul 25, 2018

The @ issue will be fixed in the next release, but for now it should work if you just replace the @ with a _

if I replace the @ with a _ I get a new error.

"Failed to check login for user [first.last_company.com] : You do not have permission to access URL 'http://local-server-name/rest/api/1.0/users/first.last_company.com' please check the user credentials associated with this account. The request returned with status code 'Unauthorized'."

The URL resolves if I enter it into the browser.

Mike Corsaro Atlassian Team Jul 25, 2018

When you visit via your browser, is it "http" or "https"?

http.

https doesn't resolve.

Mike Corsaro Atlassian Team Jul 25, 2018

Odd -- and when you use your Atlassian Account to login via that option it doesn't work either? Your Bitbucket Server credentials won't work with the Atlassian Account login, you'll need to use or register for an Atlassian Account.

I can log in with my Atlassian Account after adding id.atlassian.com to my trusted sites in IE. However, I'm trying to find the easiest path to get everyone at my company set up to use Sourcetree. Having everyone create an Atlassian account and set a trusted site in IE seems unnecessary when everything should already be in place to simply log in via bitbucket server.

Mike Corsaro Atlassian Team Jul 25, 2018

We're going to be pushing a (relatively) big update in the next week or so to our beta testers that focuses around user authentication, so keep an eye out for that.

 

It's very odd that you can't login to Bitbucket Server though. Could you try this alpha build and see if it addresses your issue? If possible, it would be awesome if you could get logs from your BBS server to see why it's failing to authenticate 🙂

The alpha build gives me the same error.

It's complaining that I don't have permission, but it's not clear what I need permission for. I have admin rights on bitbucket, which should be all i need.

Which logs should I be looking for?

Any update on this?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,416 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you