It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I do a full uninstall?

SourceTree is very confused so I want to reinstall it. I tried deleting the application but that is insufficient because it has information stored somewhere else.

2 answers

1 accepted

5 votes
Answer accepted

SourceTree stores user data in standard places which is:

~/Library/Application Support/SourceTree
~/Library/Preferences/com.torusknot.SourceTree*

But if we can help you with the 'confusion' please ask at https://support.atlassian.com - SourceTree shouldn't get in a state where you need to delete your user data.

I just deleted and recopied the app, but I still get a password prompt each time I want to communicate with the server (client server, not Bitbucket or GitHub).

I tried all the other answeres, but didn't help.

Are there any files I can delete - like you mentioned above - without having to redownload the repositories? I'm on Mac OSX.

I updated my app today and now it's stuck on install and will not continue.  Can this be fixed or should I delete everything as shown above?SourceTreeBug.jpg

I am having this same issue with the latest update, how can we fix this?

I am also having the same issue, please advise.

I had the same issue after updating sourcetree on OSX. Here's what I did about this.

 

Force close "source tree app".

Open terminal app.

"rm -rf ~/Library/Application\ Support/SourceTree" on terminal app. (This clears ALL INTERNAL DATA of source tree including repo bookmarks)

Start source tree.

 

All repository "bookmarks" are gone.

But local repository data are ok. I added existing local repos again.

Like Wesley Jordan likes this

I just successfully

  • force quite SourceTree
  • moved ~/Library/Application Support/SourceTree to the trash
  • reopened SourceTree
  • skipped the setup procedure
  • closed SourceTree
  • put back ~/Library/Application Support/SourceTree from the trash
  • reopened SourceTree
  • logged back in to my account

Guess what: Everything's back to normal. Funny thing.

Like Ivo van Zon likes this

Stefan - Excellent discovery! This worked for me. Thank you.

And on the Windows, somebody knows how to do a full uninstall?

I found some files on ~\AppData\Local\Atlassian

Like Jorge Sanchez likes this

C:\Users\<user_name>\AppData\Local\SourceTree also

Thanks, it solved mine too

All NT based Windows versions love to hide stuff in all kinds of dark corners in App_Data… Main place to look for hidden stuff

Uninstalling from control panel takes awhile for me and it appears it doesn't work. So I went to use CCleaner to remove it. Now I was able to install latest version.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

1,701 views 0 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you