How do I change a repository logo/icon in SourceTree?

How do I change a repository logo/icon in SourceTree instead of the blue circle with the bucket?

6 answers

In version 2.3 and 2.4 (for Mac) putting the icon.png to root directory just does not work, it worked pretty well before. Cleaning the cache, refreshing avatar, restarting the app nothing seems to work. sad

Same problem.
I'm using OS X 10.11.4 and Source Tree 2.4 (for Mac).

Any updates on this?

I'm having the same problem with SourceTree 2.4 running on Macintosh 10.12.3. I finally just opened the Application with Show Package Contents and replaced the default icon to octocat (since I mostly use GitHub remote repos). The default icon can be found at Contents/Resources/defaultrepoicon.png  Sorry, I know this doesn't help much if you want to individually change repo icons.

Same problem here. It worked well but not working anymore:-|

Same issue with 2.4 on Mac OS 10.11.

it is working now in the latest update, just add the icon.png in your repository root folder..

 

After upgraded latest version, this problem is resolved! THANKS :)

You put a file called "icon.png" with your desired content into the root directory of the repository and restart Sourcetree. No need to commit the file into the repository, it just needs to be there locally.

You just add 'icon.png' to root of your repo as @Thomas said and restart.

If it still does not want to show up clear the cache

on mac

rm -v ~/Library/Application\ Support/SourceTree/ImageCache/*

You need to change it on the repository and it will show up on sourcetree

I didn't know you could have icons for repositories in SourceTree! This will be so helpful! Unfortunately I couldn't get the results I expected. Did I misunderstand the intention? I'm trying to have icons as shown in this mockup image:

SourceTree icons.png

I am using a MacOS and this way worked for me:


1- Put your image file in root folder of your project.
2- Your icon needs to have this name icon.ico
3- Close your SourceTree
4- Use the command line

sudo rm -v ~/Library/Application\ Support/SourceTree/ImageCache/*

Command recommended by @Ettienne Louw thanks to you =)


5- Open your SourceTree and wait a little seconds your icon must to be appears in your project
6- If the icon do not appear just refresh the avatar and wait a little

I hope this way works for you too

Cheers,

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

557 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you