How can I setup SourceTree when the "Atlassian account" step fails?

When I choose "Use an existing account" the login always fails. 

When I choose "Go to MyAtlassian" I logon to MyAtlassian without a problem, but nothing happens. I'm just shown a licensing screen while my SourceTree setup is stuck forever at Log in to your Atlassian account.

Using MacOSX 10.11.5 and I don't know the version of SourceTree because it won't go past the setup process.

 

I see from related questions that this was also a huge problem on April 12th. Is it broken again?

---------

I should also note that I tried to delete and reinstall SourceTree without any luck. After deleting and reinstalling I'm immediately taken to the "Atlassian Account" step. The "install" and "Atlassian customer agreement" steps are skipped. 

6 answers

In terms of version...where did you get your installer? If you're using an installer for an old version, you might still be having the April 12th problem (rather than "again").

The installer was from Atlassian, version 2.2.4.

 the same issue. any help

 

The product has lost its "shine" and is not getting love from Atlasssian any more. There are other deal-breaker bugs that also aren't being addressed. Check the community discussions. Maybe next year it will get some attention and become functional again.  Until then, I recommend you move on like the rest of us.

2017 - still no way to continue past the "Atlassian account", I entered my data but you can't continue. Have to switch to another git client. Using Atlassian only when I have to (JIRA - customers). This really sucks.

20170313 - same issue. Cannot get pass the Atlassian Account setup step. The "Use an existing account" option just spins and never finish (it is still going now as I write so it's not my internet connection). "Go to My Atlassian" option goes to a confusing web page saying you can download a registration key, but since you cannot get pass the Atlassian setup screen none of the Source Tree file menu works. Guess it's time to find another Git client.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

262 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot