Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Hosted git repo password changed now SourceTree can't push

This has happened on several occasions across several SourceTree versions.  Our hosted git repo utilizes our domain passwords in order to commit.  As such our passwords change every 60 days.  I use SSH from the command line just fine however ever since the last few SourceTree updates, I am unable to utilize the setup wizard that was once present.  Therefore I cannot seem to successfully setup pushing changes back to their remotes.  Please advise.

here is a screenshot of the dialogs - Untitled.png

After I click 'allow' and enter my password, it just repeats the cycle before finally erroring out of the process.

6 answers

I just spent two hours trying to figure out how to make the latest version of SourceTree (Mac 2.4) log into our company's repo after the mandatory corporate password change. Nothing I could find on-line worked. Using the SourceTree terminal to relog in via a "git pull" did nothing. Nothing in the account menus helped.

What finally worked was going to the "Keychain Access" utility on the Mac, searching for the github server that we use and deleting ALL stored keys. Then the next time I started SourceTree, it asked for my new credentials and now it looks like I'm finally online again.

This is a SERIOUS usability flaw in the Mac version of SourceTree.

After updating my corporate password in Safari, it prompted me to update other passwords.

In Keychain Access this updated all the internet passwords (Kind = internet password) for the Bitbucket repo's domain, but not the application password (Kind = application password) which SourceTree uses.


I had to delete that one, then SourceTree prompted me for a new Password.


I couldn't find anywhere to do it from the SourceTree front-end either.

It is amazing how serious guys leave such gaps in its product.

It works for me, just deleting all the Bitbucket related keychain. Thank you!

You need to remove/edit the saved credentials in Options\Authentication.

this is for the Mac version, for which I have been unable to find any dialog/menu option for Authentication. Preferences does not contain an Options/Authentication dialog that I have found.

Sorry I have no access to a mac to check, but you need to find the place where it stores your credentials and it is going to be global to SourceTree, not in the properties of the repo.

I can confirm that this worked on Windows.

Thanks for the tip.

I found a credentials file in ~/Library/Application Data/SourceTree. The file was named <username>@STAuth-<server URL>. Deleting this file (moving it to another location, before deleting it) and restarting Sourcetree prompted a password dialog when fetching a repository on the server.

I'm running Sourcetree version 2.6.3 and Mac Sierra 10.12.6.

Application Data directory doesn't exist. 

~/Library/Application Support/SourceTree

this is right.

I have the same issue on my Mac. I have removed the SourceTree key from my "Keychain Access" utility from mac. After removing the key connect to my repo via SourceTree and perform Push/Pull activity, It asked for password and an option to save the password to keychain.  

The problem still exists in 2.7.6 (177).  Deleting "~/Library/Application Support/SourceTree/<username>@<yada yada yada>" results in SourceTree prompting for a new password.  SourceTree does not have to be restarted after the delete.

0 votes

In Windows, I found and deleted  C:\Users\<userid>\AppData\Local\Atlassian\SourceTree\passwd for a new password prompt. Serious usability issue for sure.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,901 views 4 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you