Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Filed authentication

Hi Team,

 

I am using sourcetree 3.4.2 for cloning our codebase from github. I am unable to fetch latest code from git repo. below is the screenshot for ref. I treid using both basic /auth option but still getting same error.

 

sourcetree.PNG

 

2 answers

0 votes

We are seeing the exact same error message for one of our users. Any help would be great.

The user has admin rights in BitBucket cloud. The user can login and see the repo just fine using the web browser.

But, SourceTree will not connect. We've done basic/auth, we've done an app password, we've tried re-cloning the repo, we've tried deleting the local repo and re-pulling everything.

Nothing is working. Would love to see an answer here, Atlassian. Thank you.

0 votes

FWIW...we solved our issue.

However, our issue was specific to cloning a BitBucket repo - not a GitHub repo. So, our resolution likely will not apply to the OP's situation.

(If anyone cares...the issue is that BitBucket Cloud allows users to create usernames with an "_" in them. But, the path/URL - formatted like https://username@bitbucket.org/projectname/reponame.git" - will fail out if the username has said "_" in it. Atlassian really should prevent users from creating usernames with characters that cannot validate through the Sourcetree URL.)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

2,916 views 4 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you